Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: [SOLVED] Problem with Sage Test  (Read 5512 times)

derekivey

  • Newbie
  • *
  • Posts: 9
[SOLVED] Problem with Sage Test
« on: January 24, 2011, 11:41:42 AM »

Hi all,

I'm having issues with the Sage test. I think I created the glue properly but the test keeps failing.

I'm using Namecheap and have registered the following nameservers:

ns1.d3r3k.net -> 98.117.8.73
ns2.d3r3k.net -> 98.117.8.73 (same IP, I know, this will change at some point).
ns1v6.d3r3k.net -> 2001:470:8:530::3
ns2v6.d3r3k.net -> 2001:470:8:530::2

How can I check if I set this up properly?

Thanks,
Derek
« Last Edit: January 25, 2011, 06:34:14 AM by derekivey »
Logged

marcusw

  • Newbie
  • *
  • Posts: 20
Re: Problem with Sage Test
« Reply #1 on: January 24, 2011, 12:01:48 PM »

I'm having the same problem at the moment. See my thread:
http://www.tunnelbroker.net/forums/index.php?topic=1428.0

You seem to have everything set up fine:

Code: [Select]
; <<>> DiG 9.7.1-P2 <<>> @a.gtld-servers.net. d3r3k.net
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62518
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 4, ADDITIONAL: 4
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;d3r3k.net. IN A

;; AUTHORITY SECTION:
d3r3k.net. 172800 IN NS ns1.d3r3k.net.
d3r3k.net. 172800 IN NS ns2v6.d3r3k.net.
d3r3k.net. 172800 IN NS ns1v6.d3r3k.net.
d3r3k.net. 172800 IN NS ns2.d3r3k.net.

;; ADDITIONAL SECTION:
ns1.d3r3k.net. 172800 IN A 98.117.8.73
ns2v6.d3r3k.net. 172800 IN AAAA 2001:470:8:530::2
ns1v6.d3r3k.net. 172800 IN AAAA 2001:470:8:530::3
ns2.d3r3k.net. 172800 IN A 98.117.8.73

;; Query time: 37 msec
;; SERVER: 2001:503:a83e::2:30#53(2001:503:a83e::2:30)
;; WHEN: Mon Jan 24 14:58:38 2011
;; MSG SIZE  rcvd: 191

So I'm guessing the problem is with the test. Could you post the test output so we can compare it to mine?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2671
Re: Problem with Sage Test
« Reply #2 on: January 24, 2011, 12:11:00 PM »

I'm not sure the problem is with the test if theres 100+ other people that have passed ;)

I take it you two have seen the troubleshooting slide here?

http://ipv6.he.net/presentations/sage.pdf
Logged

derekivey

  • Newbie
  • *
  • Posts: 9
Re: Problem with Sage Test
« Reply #3 on: January 24, 2011, 12:22:49 PM »

I've followed the troubleshooting section in that PDF and it looks fine:

Code: [Select]
-bash-3.00$ /usr/sbin/dig ns d3r3k.net +trace

; <<>> DiG 9.2.4 <<>> ns d3r3k.net +trace
;; global options:  printcmd
.                       346147  IN      NS      b.root-servers.net.
.                       346147  IN      NS      g.root-servers.net.
.                       346147  IN      NS      j.root-servers.net.
.                       346147  IN      NS      f.root-servers.net.
.                       346147  IN      NS      l.root-servers.net.
.                       346147  IN      NS      e.root-servers.net.
.                       346147  IN      NS      h.root-servers.net.
.                       346147  IN      NS      i.root-servers.net.
.                       346147  IN      NS      a.root-servers.net.
.                       346147  IN      NS      m.root-servers.net.
.                       346147  IN      NS      d.root-servers.net.
.                       346147  IN      NS      c.root-servers.net.
.                       346147  IN      NS      k.root-servers.net.
;; Received 492 bytes from 10.50.1.12#53(10.50.1.12) in 2 ms

net.                    172800  IN      NS      a.gtld-servers.net.
net.                    172800  IN      NS      l.gtld-servers.net.
net.                    172800  IN      NS      d.gtld-servers.net.
net.                    172800  IN      NS      h.gtld-servers.net.
net.                    172800  IN      NS      g.gtld-servers.net.
net.                    172800  IN      NS      k.gtld-servers.net.
net.                    172800  IN      NS      m.gtld-servers.net.
net.                    172800  IN      NS      b.gtld-servers.net.
net.                    172800  IN      NS      i.gtld-servers.net.
net.                    172800  IN      NS      j.gtld-servers.net.
net.                    172800  IN      NS      f.gtld-servers.net.
net.                    172800  IN      NS      c.gtld-servers.net.
net.                    172800  IN      NS      e.gtld-servers.net.
;; Received 512 bytes from 192.228.79.201#53(b.root-servers.net) in 248 ms

d3r3k.net.              172800  IN      NS      ns1.d3r3k.net.
d3r3k.net.              172800  IN      NS      ns2.d3r3k.net.
d3r3k.net.              172800  IN      NS      ns1v6.d3r3k.net.
d3r3k.net.              172800  IN      NS      ns2v6.d3r3k.net.
;; Received 191 bytes from 192.5.6.30#53(a.gtld-servers.net) in 198 ms

d3r3k.net.              10800   IN      NS      ns2.d3r3k.net.
d3r3k.net.              10800   IN      NS      ns1v6.d3r3k.net.
d3r3k.net.              10800   IN      NS      ns2v6.d3r3k.net.
d3r3k.net.              10800   IN      NS      ns1.d3r3k.net.
;; Received 191 bytes from 98.117.8.73#53(ns1.d3r3k.net) in 189 ms

-bash-3.00$ /usr/sbin/dig aaaa ns1v6.d3r3k.net @a.gtld-servers.net

; <<>> DiG 9.2.4 <<>> aaaa ns1v6.d3r3k.net @a.gtld-servers.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1201
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 4, ADDITIONAL: 4

;; QUESTION SECTION:
;ns1v6.d3r3k.net.               IN      AAAA

;; AUTHORITY SECTION:
d3r3k.net.              172800  IN      NS      ns1.d3r3k.net.
d3r3k.net.              172800  IN      NS      ns2v6.d3r3k.net.
d3r3k.net.              172800  IN      NS      ns1v6.d3r3k.net.
d3r3k.net.              172800  IN      NS      ns2.d3r3k.net.

;; ADDITIONAL SECTION:
ns1.d3r3k.net.          172800  IN      A       98.117.8.73
ns2v6.d3r3k.net.        172800  IN      AAAA    2001:470:8:530::2
ns1v6.d3r3k.net.        172800  IN      AAAA    2001:470:8:530::3
ns2.d3r3k.net.          172800  IN      A       98.117.8.73

;; Query time: 199 msec
;; SERVER: 192.5.6.30#53(a.gtld-servers.net)
;; WHEN: Mon Jan 24 15:19:35 2011
;; MSG SIZE  rcvd: 191

marcusw: here is my test output:

Code: [Select]
Domain: d3r3k.net
Domains TLD: net
NS Records: dns1.registrar-servers.com.
-TLD: com
-Server: f.gtld-servers.net.
-Output: No Record
-Server: l.gtld-servers.net.
-Output: No Record
-Server: k.gtld-servers.net.
-Output: No Record
-Server: a.gtld-servers.net.
-Output: No Record
-Server: i.gtld-servers.net.
-Output: No Record
-Server: e.gtld-servers.net.
-Output: No Record
-Server: g.gtld-servers.net.
-Output: No Record
-Server: b.gtld-servers.net.
-Output: No Record
-Server: c.gtld-servers.net.
-Output: No Record
-Server: j.gtld-servers.net.
-Output: No Record
-Server: h.gtld-servers.net.
-Output: No Record
-Server: d.gtld-servers.net.
-Output: No Record
-Server: m.gtld-servers.net.
-Output: No Record
NS Records: dns2.registrar-servers.com.
-TLD: com
-Server: l.gtld-servers.net.
-Output: No Record
-Server: k.gtld-servers.net.
-Output: No Record
-Server: a.gtld-servers.net.
-Output: No Record
-Server: d.gtld-servers.net.
-Output: No Record
-Server: b.gtld-servers.net.
-Output: No Record
-Server: c.gtld-servers.net.
-Output: No Record
-Server: g.gtld-servers.net.
-Output: No Record
-Server: m.gtld-servers.net.
-Output: No Record
-Server: f.gtld-servers.net.
-Output: No Record
-Server: e.gtld-servers.net.
-Output: No Record
-Server: h.gtld-servers.net.
-Output: No Record
-Server: i.gtld-servers.net.
-Output: No Record
-Server: j.gtld-servers.net.
-Output: No Record
NS Records: dns3.registrar-servers.com.
-TLD: com
-Server: m.gtld-servers.net.
-Output: No Record
-Server: c.gtld-servers.net.
-Output: No Record
-Server: g.gtld-servers.net.
-Output: No Record
-Server: i.gtld-servers.net.
-Output: No Record
-Server: j.gtld-servers.net.
-Output: No Record
-Server: l.gtld-servers.net.
-Output: No Record
-Server: a.gtld-servers.net.
-Output: No Record
-Server: d.gtld-servers.net.
-Output: No Record
-Server: k.gtld-servers.net.
-Output: No Record
-Server: b.gtld-servers.net.
-Output: No Record
-Server: f.gtld-servers.net.
-Output: No Record
-Server: e.gtld-servers.net.
-Output: No Record
-Server: h.gtld-servers.net.
-Output: No Record
d3r3k.net

It seems to be looking up the old nameservers (I changed over to my nameservers yesterday).

Derek
Logged

marcusw

  • Newbie
  • *
  • Posts: 20
Re: Problem with Sage Test
« Reply #4 on: January 24, 2011, 12:58:09 PM »

It seems to be looking up the old nameservers (I changed over to my nameservers yesterday).

Same problem as me. I changed over from (or rather added an IPv6 server in addition to) my registrar's servers some hours ago. Perhaps it's not updating the way it should? Perhaps it locks to the nameservers one starts with (man, that would suck)? Who knows. I sent a message to ipv6@he.net asking what was going on and included a link to both of these threads. I'll let you know if the reply is anything useful.
Logged

derekivey

  • Newbie
  • *
  • Posts: 9
Re: Problem with Sage Test
« Reply #5 on: January 24, 2011, 12:59:46 PM »

Thanks!
Logged

marcusw

  • Newbie
  • *
  • Posts: 20
Re: Problem with Sage Test
« Reply #6 on: January 24, 2011, 09:40:50 PM »

Ok, my problem seems to be resolved now (see my sig? :p). All I had to do was wait for something inside the test to time out (12 hours?). I can also note that you only need one server with an IPv6 glue record, it doesn't matter if you also have IPv4-only hosts listed as well.

Sorry to the HE guys for thinking their stuff was broken...but with two of us having the same problem at the same time and no records of this happening previously, things were a bit confusing.
Logged

derekivey

  • Newbie
  • *
  • Posts: 9
Re: Problem with Sage Test
« Reply #7 on: January 25, 2011, 06:33:58 AM »

Mine just worked too!

Thanks,
Derek
Logged

chandro

  • Newbie
  • *
  • Posts: 27
  • hello!!
    • Chandro & Co
Re: [SOLVED] Problem with Sage Test
« Reply #8 on: April 04, 2011, 01:18:52 PM »

im on this test, and my domain is chandro.mx

let see if i can make it work.
Logged
2001:0:0:7::B0ND