Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Can't get IPv6 Tunnel to Work, Mac OS X 10.6  (Read 6594 times)

awesomezguy

  • Newbie
  • *
  • Posts: 3
Can't get IPv6 Tunnel to Work, Mac OS X 10.6
« on: January 27, 2011, 09:07:38 AM »

Hey,

I'm on Mac OS X 10.6 Snow Leopard with the Cisco EPC2425 modem+router (my ISP insists on a combined one, and flashing with DD-WRT is a no no :().

I originally configured with these options:
Code: [Select]
ifconfig gif0 create
ifconfig gif0 tunnel MY.EXTERNAL.IPV4.ADDRESS 216.66.80.26
ifconfig gif0 inet6 2001:470:1f08:136b::2 2001:470:1f08:136b::1 prefixlen 128
route -n add -inet6 default 2001:470:1f08:136b::1

But got this error
Code: [Select]
bash-3.2# ping6 he.net
PING6(56=40+8+8 bytes) fe80::226:4aff:fe19:e8c%gif0 --> 2001:470:0:76::2
ping6: sendmsg: Can't assign requested address
ping6: wrote he.net 16 chars, ret=-1
Request timeout for icmp_seq=0
ping6: sendmsg: Can't assign requested address
ping6: wrote he.net 16 chars, ret=-1

I then decided to try using my internal DHCP server assigned IP with this line:
Code: [Select]
ifconfig gif0 tunnel 192.168.1.14 216.66.80.26
But got this slightly different error:
Code: [Select]
bash-3.2# ping6 he.net
PING6(56=40+8+8 bytes) fe80::226:4aff:fe19:e8c%gif0 --> 2001:470:0:76::2
Request timeout for icmp_seq=0
Request timeout for icmp_seq=1
Request timeout for icmp_seq=2

Anybody got any suggestions for me? I really like being slightly ahead in web technologies (let's lead by example ;)), so I'd love to set up an IPv6 tunnel.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2667
Re: Can't get IPv6 Tunnel to Work, Mac OS X 10.6
« Reply #1 on: January 27, 2011, 09:13:28 AM »

Since you are behind nat, you need to use your 192.168.1.14 address to create the tunnel 

Is your router passing protocol 41 traffic to your mac?
Logged

awesomezguy

  • Newbie
  • *
  • Posts: 3
Re: Can't get IPv6 Tunnel to Work, Mac OS X 10.6
« Reply #2 on: January 27, 2011, 09:14:58 AM »

As you saw in my post, I did change the config to use my internal IP, but still got timeouts.
How can I check if my router is passing protocol41?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2667
Re: Can't get IPv6 Tunnel to Work, Mac OS X 10.6
« Reply #3 on: January 27, 2011, 09:30:56 AM »

There isn't a way to test...you'll want to either turn off the firewall on your router to add your host to the DMZ of your router
Logged

awesomezguy

  • Newbie
  • *
  • Posts: 3
Re: Can't get IPv6 Tunnel to Work, Mac OS X 10.6
« Reply #4 on: January 27, 2011, 09:38:23 AM »

Done both, still won't work :(
Logged