Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Google thinks my prefix is in Norway - It's not  (Read 9656 times)

DTCNEO

  • Newbie
  • *
  • Posts: 2
Google thinks my prefix is in Norway - It's not
« on: February 17, 2011, 09:22:54 PM »

So, I'm not exactly sure what to do about this and I was hoping to get some help, or at-least pointed in the right direction. When accessing google.com over IPv6 google is detecting that I'm in Norway, and redirecting me to google.no. If I force my computer to prefer IPv4 over IPv6 I can reach google.com just fine. It appears that google thinks my entire prefix resides in Norway! If it was just me being affected I would just use google.com/ncr, but I have my tunnel configured on my router, which is providing native IPv6 connectivity to my LAN, so all users are being affected. I could also either stop my DNS server from using HE's DNS servers as forward lookup servers, or just disable IPv6 on my LAN, but I'd rather not. Google has a page to report location detection problems, but it only accepts IPv4 addresses and there's nowhere to type a comment. Does anyone have any idea what I can do to resolve this problem?
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1723
Re: Google thinks my prefix is in Norway - It's not
« Reply #1 on: February 17, 2011, 09:31:21 PM »

I think it's a Google problem, since even at the office, I was getting sent to www.google.no, however it was 12ms away, and being in California, that is highly unlikely. Also accessing maps.google.com and other app hostnames, kept me in .com and not go to .no. Since this seems to be an issue on the Google side, I simply changed www.google.no to display in English and fired off an email :)

-edit- took a peek again and everything is now going 174ms away from SFBA, so sent them an updated email.
« Last Edit: February 17, 2011, 09:38:56 PM by broquea »
Logged

jimb

  • Hero Member
  • *****
  • Posts: 805
  • ^^^ Warped picture
Re: Google thinks my prefix is in Norway - It's not
« Reply #2 on: February 17, 2011, 09:51:37 PM »

So, I'm not exactly sure what to do about this and I was hoping to get some help, or at-least pointed in the right direction. When accessing google.com over IPv6 google is detecting that I'm in Norway, and redirecting me to google.no. If I force my computer to prefer IPv4 over IPv6 I can reach google.com just fine. It appears that google thinks my entire prefix resides in Norway! If it was just me being affected I would just use google.com/ncr, but I have my tunnel configured on my router, which is providing native IPv6 connectivity to my LAN, so all users are being affected. I could also either stop my DNS server from using HE's DNS servers as forward lookup servers, or just disable IPv6 on my LAN, but I'd rather not. Google has a page to report location detection problems, but it only accepts IPv4 addresses and there's nowhere to type a comment. Does anyone have any idea what I can do to resolve this problem?
Mebbe they saw your email address and thought you were Thor?
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1723
Re: Google thinks my prefix is in Norway - It's not
« Reply #3 on: February 17, 2011, 10:01:15 PM »

Got a speedy reply from them that their GeoIP team will start looking into it.
Logged

DTCNEO

  • Newbie
  • *
  • Posts: 2
Re: Google thinks my prefix is in Norway - It's not
« Reply #4 on: February 19, 2011, 09:53:58 AM »

Got a speedy reply from them that their GeoIP team will start looking into it.

Good to hear! My boss thought I was playing a joke on her when she came into work yesterday. Apparently she interpreted google.no as no Google, so she asked me why I turned off her access to Google. Was quite a funny conversation actually. I ended up removing Hurricane Electric's DNS server addresses from the list of forwarders our DNS server uses for the time being HE's DNS server is the only whitelisted DNS server we use, so that should stop the complaints at work.
Logged

jonnymmm

  • Newbie
  • *
  • Posts: 1
Re: Google thinks my prefix is in Norway - It's not
« Reply #5 on: February 21, 2011, 09:32:22 AM »

I'm having a similar problem, that started either yesterday or the day before where Google thinks I'm from Canada (I'm actually in California, using Fremont 2).
Logged

alanho

  • Newbie
  • *
  • Posts: 5
Re: Google thinks my prefix is in Norway - It's not
« Reply #6 on: February 21, 2011, 10:45:51 PM »

I have the same issue. I were in Hong kong but were pointed to google.no.
BTW, I found enabling he.net slow down my connection quite a lot.  Will investigate the cause.
Logged

mkuron

  • Newbie
  • *
  • Posts: 3
Google thinks my prefix is in Poland - It's not
« Reply #7 on: February 22, 2011, 08:31:31 AM »

I'm on the Frankfurt tunnel server and get redirected to Google Poland...

Code: [Select]
curl -I -6 http://www.google.com | grep Location
Location: http://www.google.pl/

IP Geolocation is getting even more absurd now that we have IPv6...



EDIT 2/25: Apparently Frankfurt just moved 1000 kilometers to the north-west and now is located in Denmark:
Code: [Select]
curl -6 -I http://www.google.com | grep Location
Location: http://www.google.dk/

EDIT 3/20: And now a couple days ago it moved 1500 kilometers to the south to settle down in Slovenia. Let's see where it goes next.
Code: [Select]
curl -6 -I http://www.google.com | grep Location
Location: http://www.google.si/
« Last Edit: March 20, 2011, 04:02:20 AM by mkuron »
Logged
tserv6.fra1.ipv6.he.net

Ninho

  • Full Member
  • ***
  • Posts: 138
Re: Google thinks my prefix is in Poland - It's not
« Reply #8 on: February 27, 2011, 03:12:26 AM »

I'm on the Frankfurt tunnel server and get redirected to Google Poland...
EDIT 2/25: Apparently Frankfurt just moved 1000 kilometers to the north-west and now is located in Denmark

And me (going through HE Frankfürt too) am being seen as from "România" ;=)

Oh, well... a great opportunity for learning all about  "vampyres" isn't it ?

Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1723
Re: Google thinks my prefix is in Norway - It's not
« Reply #9 on: February 28, 2011, 05:47:32 PM »

An update:

Google believed they solved the issue yesterday after making some changes, however it continues with the same behavior. The issue is still open with their IPgeo team, and they will let us know when it has been fixed.

Kudos to Google for looking into this and working to fix it.
Logged

Gapppy

  • Newbie
  • *
  • Posts: 7
Re: Google thinks my prefix is in Norway - It's not
« Reply #10 on: March 20, 2011, 02:47:30 PM »

Try www.google.ru in my situation, and i am from Slovenia. In cyrilic look google sexy but not to me.
Logged

mkuron

  • Newbie
  • *
  • Posts: 3
Re: Google thinks my prefix is in Norway - It's not
« Reply #11 on: May 07, 2011, 01:27:59 AM »

Just thought I'd let you know that at least for me, it seems like it's been fixed for a couple days/weeks now.

EDIT 05/22: Well, guess I'm back to Poland now.
« Last Edit: May 22, 2011, 02:38:34 AM by mkuron »
Logged
tserv6.fra1.ipv6.he.net