Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Can't get Tunnel to work - Netgear WGR614v6  (Read 4005 times)

Pasche6Net

  • Newbie
  • *
  • Posts: 4
Can't get Tunnel to work - Netgear WGR614v6
« on: February 22, 2011, 08:28:35 PM »

Newbie says: Well, I believe I've read all the instructions and tried everything.  
I'm running Ubuntu Maverick 10.10 behind a Netgear WGR614v6 router.

I had Miredo running today and could easily ping6 ipv6.google.com and got results.  (Then I disabled Miredo).

I ran these both the route2 and the net-tools commands, being sure to replace my NAT'd IP address into the route2 commands.  No joy either way.

Here's the net-tools version:
ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::209.51.181.2
ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:1f10:cca::2/64
route -A inet6 add ::/0 dev sit1

then when I ping6, it just hangs.  when I ^c, I get "0% transmitted".

I thought it was the Netgear router, but if Teredo/Miredo works through the router, than doesn't that mean the HE tunnel should also work?  So that leaves me with my Ubuntu commands above.

I'm running on a wireless network as 10.0.0.x -- the interface is wlan0.

I'll post the ifconfig in an edit or next post. --When I run the above commands, I can no longer access these forums  :(

=====
UPDATE
I connected directly to my cable modem, and ran everything else as above, and the tunnel works. (Dancing kame.)
Sadly, that must mean it's the router. 

Why does Teredo/Miredo work through NAT but not HE tunnel?

Does _anyone_ know how to get the HE tunnel working through WGR614v6 router?  It must not be passing Protocol 41 through the NAT.  I have telnet access to the router but there are no iptables commands because it has the VxWorks commands instead.
« Last Edit: February 23, 2011, 04:33:03 AM by Pasche6Net »
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2699
Re: Can't get Tunnel to work - Netgear WGR614v6
« Reply #1 on: February 23, 2011, 05:01:28 AM »

Quote
Why does Teredo/Miredo work through NAT but not HE tunnel?

The simple reason is your netgear isn't passing protocol41.  Teredo doesn't need proto41, so it just "works"

Can you put the router in bridge mode?  Is there a DMZ mode in it?
Logged

Pasche6Net

  • Newbie
  • *
  • Posts: 4
Re: Can't get Tunnel to work - Netgear WGR614v6
« Reply #2 on: February 23, 2011, 05:20:05 AM »

There is no bridge mode.  There is DMZ. It has remained set to my Ubuntu box's 10.0.0.x address, but that doesn't seem to change anything.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2699
Re: Can't get Tunnel to work - Netgear WGR614v6
« Reply #3 on: February 23, 2011, 05:40:44 AM »

Yeah, it sounds like it's not passing protocol41.

Can you attach your computer directly to your modem/cable feed and try again?
Logged

Pasche6Net

  • Newbie
  • *
  • Posts: 4
Re: Can't get Tunnel to work - Netgear WGR614v6
« Reply #4 on: February 23, 2011, 12:58:23 PM »

Can you attach your computer directly to your modem/cable feed and try again?

When I attach it directly to the cable modem, it works great. I was hoping to still get it to work with the router so I could have wireless access as well.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2699
Re: Can't get Tunnel to work - Netgear WGR614v6
« Reply #5 on: February 23, 2011, 01:08:00 PM »

oh, sorry, I just saw that under the "update" in your first post.

If your DMZ function doesn't work, I'm afraid there isn't much hope.  Have you checked for a firmware upgrade?  Does DDWRT or something else work on it?
Logged

Pasche6Net

  • Newbie
  • *
  • Posts: 4
Re: Can't get Tunnel to work - Netgear WGR614v6
« Reply #6 on: February 23, 2011, 01:35:46 PM »

There's no firmware upgrade... and no DDWRT. Just bricking. 

I found a way to telnet in, but all you get are these VxWorks commands.  Not very helpful.  It has a DMZ setting, but I guess for whatever reason that isn't enough.  Oh well I think this router is unusable for this purpose.
Logged