Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Can't get ipv4.tunnelbroker.net/ipv4_end.php to work  (Read 5659 times)

dwmuller

  • Newbie
  • *
  • Posts: 1
Can't get ipv4.tunnelbroker.net/ipv4_end.php to work
« on: July 31, 2011, 10:08:23 AM »

I haven't been able to get this URL to work. It keeps giving me an error and spitting out the syntax help. Tried it from a script first, then experimented from a browser window. (That should work, right?)

I've quadruple-checked the syntax, tunnel ID, etc., and searched the forums for help. No joy.

Any suggestions?
Logged

jrocha

  • Network Architect
  • Jr. Member
  • **
  • Posts: 66
Re: Can't get ipv4.tunnelbroker.net/ipv4_end.php to work
« Reply #1 on: July 31, 2011, 01:52:53 PM »

Are you connecting over http or https? Is your password properly md5-hashed? Have you tried the https://USERNAME:PASSWORD@ version?
Logged

vivkkrishnan2005

  • Newbie
  • *
  • Posts: 1
Re: Can't get ipv4.tunnelbroker.net/ipv4_end.php to work
« Reply #2 on: July 31, 2011, 02:15:25 PM »

the second does not work, but the first works. did not try the third. also in the first, u have to use your user id, not user name!
Logged

docbill

  • Newbie
  • *
  • Posts: 5
Re: Can't get ipv4.tunnelbroker.net/ipv4_end.php to work
« Reply #3 on: August 11, 2011, 10:12:53 AM »

This script seems to have been updated recently.  I set my router up months ago to automatically update my IPv4 address, using the TomatoUSB DDNS feature.   Since my IP address rarely changes, I did notice the script is broken until this morning.   It looks like there have been the following changes:

1. The parameter ip=AUTO must be passed, as the script no longer takes this as default when not specifying an ip parameter.
2. The USERNAME:PASSWORD@ syntax does not appear to work at all...  Not that I was using this before, it is just something I tried when my normal URL was not working...
3. The address must be ipv4.tunnelbroker.net.   Using www.tunnelbroker.net/ipv4_end.php no longer works at all.  The reason seems to be that for www.tunnelbroker.net the IPv6 address always takes priority.  So if you don't have a working tunnel you can't open the site, and if you do have a working tunnel, then your IPv4 address is already set to the correct value.
4. HE now seems to require your router to allow IPv4 ICMP.  Previously, I was able to set my IPv4 address without enabling ICMP...

I haven't submitted a patch for TomatoUSB so the DDNS setting work again, however, doing a wget on a hand crafted URL seems to work as expected.




I haven't been able to get this URL to work. It keeps giving me an error and spitting out the syntax help. Tried it from a script first, then experimented from a browser window. (That should work, right?)

I've quadruple-checked the syntax, tunnel ID, etc., and searched the forums for help. No joy.

Any suggestions?

« Last Edit: August 11, 2011, 10:22:42 AM by docbill »
Logged

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 419
Re: Can't get ipv4.tunnelbroker.net/ipv4_end.php to work
« Reply #4 on: August 14, 2011, 04:58:08 AM »

1.  Ever since the script started taking AUTO as a valid option for the IP, it's been required to be there.  Only on https w/USER:PASS syntax does it default to AUTO.
2.  Certain command line clients won't try HTTP-Auth by default, even when given credentials.  They'll make the request without creds, verify that the site wants them, then redo the request with them.  There's usually a command line option for those to let them know to do it anyway.  (wget: --auth-no-challenge) I've made a change which should prompt for it now, and that shouldn't break backwards compatibility based on some tests with curl and wget I've done.
3.  That's the way it's always had to be.  www.tunnelbroker.net is setup dual-stack, which is why we have the protocol specific hostnames in the case you're lacking reachability on one or the other.  You can also use the command line client's protocol specific option flags (-4/-6 for curl and wget).
4.  IPv4 ICMP_ECHO replies from designated tunnel endpoints have been required since the earliest days of the broker.
Logged

trevorwarwick

  • Newbie
  • *
  • Posts: 11
Re: Can't get ipv4.tunnelbroker.net/ipv4_end.php to work
« Reply #5 on: August 17, 2011, 09:53:16 AM »

I haven't been able to get this URL to work. It keeps giving me an error and spitting out the syntax help. Tried it from a script first, then experimented from a browser window. (That should work, right?)

I've quadruple-checked the syntax, tunnel ID, etc., and searched the forums for help. No joy.

Any suggestions?


I just got it working, had problems at first, and my problem was the "apikey" parameter. This isn't your username, it's the "user id" which is a hex string displayed on your tunnelbroker account home page .
Logged