Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Weird Outlook problem when IPv6 is enabled  (Read 10866 times)

bartgrefte

  • Newbie
  • *
  • Posts: 38
Weird Outlook problem when IPv6 is enabled
« on: September 07, 2011, 04:43:54 AM »

Hi,

After my desktop pc died last night, I switched to my laptop. When I set my email account with my own domainname in Outlook, the test-emails where send successfully. However, when Outlook tried to check for new emails in my inbox I got this error:
Quote
Task 'server name - Sending and Receiving' reported error (0x800ccc0f): 'The connection to the server was interrupted. If this problem continues, contact the server administrator or Internet service provider (ISP).'

After calling the host, who said they did not see my ip address in the logs, I tried telnet from CMD to try contacting the mailserver, no go, blinking _. But using that command when logged on to my pfSense router it worked. Then I disabled IPv6 on my laptop using ipv6 uninstall, Outlook immediately worked like it should.

So... any idea's why Outlook cannot reach the emailserver for incoming emails when IPv6 is enabled?
This is the IPv6 howto I used: http://www.xaero.org/index.php/archive/configuring-a-6tin4-tunnel-on-the-pfsense-firewall/

Not sure if this matters, but outgoing emails (which work with IPv6 enabled) use port 587 while incoming (that gives the error) uses 110.

With regards,

Bart Grefte
Logged

johnpoz

  • Full Member
  • ***
  • Posts: 114
Re: Weird Outlook problem when IPv6 is enabled
« Reply #1 on: September 07, 2011, 05:48:51 AM »

What is your host??  I would guess they have a IPV6 address that you tried to telnet too?  But its not listening on that IPv6

As to those instructions for pfsense, if you want to use ipv6 on pfsense I would HIGHLY suggest you move to 2.0 and actual pfsense method.

http://doc.pfsense.org/index.php/Using_IPv6_on_2.0

Windows likes to use ipv6 over ipv4, unless you tell it not too.

prefer ipv4 over ipv6
reg add hklm\system\currentcontrolset\services\tcpip6\parameters /v DisabledComponents /t REG_DWORD /d 32
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715
Re: Weird Outlook problem when IPv6 is enabled
« Reply #2 on: September 07, 2011, 06:06:40 AM »

I'm with John...I'll bet your server has an IPv6 record.

I wouldn't think the problem is even related to Outlook (I don't think it knows what protocol it's using) But I can tell you that I've seen Outlook 2003 work with IPv6
Logged

bartgrefte

  • Newbie
  • *
  • Posts: 38
Re: Weird Outlook problem when IPv6 is enabled
« Reply #3 on: September 07, 2011, 06:28:02 AM »

My host: http://www.oxilion.nl/
Not sure if it matters, but the mailserver for outgoing is the same as incoming, mail.mydomainname.nl. So why is only incoming failing instead of both incoming and outgoing?

I am not planning to switch to a newer pfSense, I'm gonna ditch it for Debian, eventually.
(Still trying to gather info about how to set Debian up as a router and how to modify it for use on a CF-card.)

According to pfSense (where telnet does work) it seems to have an IPv6 address.
Quote
$ telnet mail.mydomainname.nl 110
Trying 2a00:d10:1****...
Trying 93.186.***.**...
Connected to mydomainname.nl.
Escape character is '^]'.
+OK Dovecot DA ready.

If the problem is caused because it is not listening on IPv6 and that regkey solves it, wouldn't that cause áll apps to use IPv4 instead of IPv6?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715
Re: Weird Outlook problem when IPv6 is enabled
« Reply #4 on: September 07, 2011, 06:34:52 AM »

Code: [Select]
[carl@mars ~]$ host mail.mydomainname.nl
mail.mydomainname.nl has address 89.105.197.166

Your server doesn't have an IPv6 record.  What happens if you turn off your firewall and try?
Logged

johnpoz

  • Full Member
  • ***
  • Posts: 114
Re: Weird Outlook problem when IPv6 is enabled
« Reply #5 on: September 07, 2011, 08:31:13 AM »

that is really the domain name?? "mail.mydomainname.nl"

It looked like something you put in to hide the actual host name??  Then when you snipped out the IPs, just pointed again to that not being the actual host name.

As to that reg key on windows, it would not stop an app from actually using ipv6 - it would stop default use of ipv6 over ipv4.  I don't have any issues accessing ipv6 resources at all.  If that is what I choose to do, but what that reg entry does is have windows prefer to use ipv4 if there is both vs picking the ipv6 one over ipv4

But yeah from your telnet test it tried to do ipv6, failed so failed over to ipv4 -- I do not believe windows is that smart ;)  So if outlook tried to connect to ipv6 of your host and it failed, it would just fail.

as to using your fav linux distro as a router vs an actual firewall distro - hey more power too you, I just can not be bothered - I would rather use something that is geared directly towards being a router/firewall that multiple people who are way smarter than me when it comes to that sort of thing spend lots and lots of time working on perfecting vs a generic distro I setup to be a router.  But hey thats my preference, you clearly can have any linux distro be a router/firewall that is for sure.
« Last Edit: September 07, 2011, 08:40:17 AM by johnpoz »
Logged

bartgrefte

  • Newbie
  • *
  • Posts: 38
Re: Weird Outlook problem when IPv6 is enabled
« Reply #6 on: September 07, 2011, 08:51:41 AM »

Off course it's not real, thought that would be obvious :D
I removed it because not everyone has to know it ;)

The command cholzhauer used shows both an IPv4 and IPv6 address if I run it from pfSense's console.
And according to my nephew (who works at that host) the mailserver should be capable of communicating through IPv6.
But I'm not 100% sure if that also includes POP3 traffic. (gonna ask that to be sure)

Precisely, I figured, why not take a normal distro and do it my way? This way I only have to get what I need and keep things as simple/light/small as possible. The main issue I have yet to solve is what to do when using a CF-card, already found some tips about how to limit writes but a readonly FS and running from RAM would be better.
« Last Edit: September 07, 2011, 09:13:09 AM by bartgrefte »
Logged

johnpoz

  • Full Member
  • ***
  • Posts: 114
Re: Weird Outlook problem when IPv6 is enabled
« Reply #7 on: September 07, 2011, 09:28:40 AM »

Well simple enough to do a nmap to the server over to its IPv6 address.  Since you failed to connect to it on pop3 port, I would have to say its not listening if you can ping it for example to validate ipv6 connectivity.
Logged

bartgrefte

  • Newbie
  • *
  • Posts: 38
Re: Weird Outlook problem when IPv6 is enabled
« Reply #8 on: September 07, 2011, 09:51:26 AM »

Nmap is not recognized as a command...

pfSense can ping and get response from the IPv6 address, XP too when using ping6 mail.mydomainname.nl.

Just to try, I switched to 7 (having a tripleboot sometimes comes in handy). When I do a telnet from 7 with IPv6 enabled and with ESET Smart Security set to interactive mode, I see that 7 first tries to connect using the IPv6 address and a few seconds later the IPv4 which works. Apparently XP does not stop trying when there's no answer.
Logged

johnpoz

  • Full Member
  • ***
  • Posts: 114
Re: Weird Outlook problem when IPv6 is enabled
« Reply #9 on: September 07, 2011, 01:09:22 PM »

Well you never said what OS you were using in the first place, not sure if that reg entry will work on xp. I tend to not think so.

Again it seems clear that your host is not listening on 110 on ipv6..  So that would explain why something that is trying to use IPv6 would not work ;)

If you don't want change your OS to prefer ipv4 over ipv6, then either enable or get you host to enable pop on ipv6 or another option would be to just create a host file entry that points to an IPv4 address and use that in your outlook setup.  Only issue with that would be if the actual IP of the host changes, you would have to update your host file.

As to nmap not working on your pfsense, when did I say it would?  But it would if you installed it or just run it from another machine on your network that uses ipv6, etc.  But there is a package for nmap for pfsense so you could install it if you want.  I just normally run it from one of my linux boxes or even window - it can run on quite a few OSes.

If you PM me your host name I would be happy to scan it for you to see what ports its listening on its ipv6 address..  But just because you enable IPv6 on a box does not mean all its services you might be running will bind to that IPv6 address.  Most services require you to enable it to do that, some services do not even support IPv6 even though the OS might, etc.

from your telnet command there looks like your server is running dovecat for pop3, so for it to listen on both ipv4 and ipv6 you would have to use http://wiki.dovecot.org/MainConfig

"*" listens in all IPv4 interfaces. [::]" listens in all IPv6 interfaces. Use "*,[::]" for listening both IPv4 and IPv6.

« Last Edit: September 07, 2011, 01:11:36 PM by johnpoz »
Logged

bartgrefte

  • Newbie
  • *
  • Posts: 38
Re: Weird Outlook problem when IPv6 is enabled
« Reply #10 on: September 08, 2011, 01:03:04 AM »

Woops :P

Well, I have an answer from the host. Turns out the SMTP server was listening on IPv6 (explains why outgoing works), however the POP3/IMAP server was not.

They fixed that and now it works, with IPv6 enabled ;D

Hmm, I also tried NMAP on XP, not recognized there either.

Leaves the question why XP did not fall back to IPv4 when it did not get an answer using IPv6, while 7 did try IPv4.
« Last Edit: September 08, 2011, 06:41:12 AM by bartgrefte »
Logged

k1mu

  • Newbie
  • *
  • Posts: 36
Re: Weird Outlook problem when IPv6 is enabled
« Reply #11 on: September 09, 2011, 05:36:17 AM »

Hmm, I also tried NMAP on XP, not recognized there either.

Leaves the question why XP did not fall back to IPv4 when it did not get an answer using IPv6, while 7 did try IPv4.

nmap isn't part of windows. You can find instructions for installing it on windows from here.

As to why XP didn't fall back - I'd guess that that's an old enough OS that the idea of running dual-stack wasn't well implemented.
Logged