Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Destination unreachable: Address unreachable (from tunnel server Amsterdam)  (Read 6127 times)

rb20

  • readonly_member
  • Newbie
  • *
  • Posts: 3

I have created a ipv6 tunnel on a Ubuntu 11.10 server with the follow commands (Linux-route2):

Code: [Select]
modprobe ipv6
ip tunnel add he-ipv6 mode sit remote 216.66.84.46 local 178.**.50.173 ttl 255
ip link set he-ipv6 up
ip addr add 2001:470:**:1664::2/64 dev he-ipv6
ip route add ::/0 dev he-ipv6
ip -f inet6 addr
I have already try linux-net-tools but they doesn't give any repsonse

But when i ping a ipv6 adres, i will see "Destination unreachable: Address unreachable"

Code: [Select]
root@ubuntu-serv:~/csf# ping6 ipv6.google.com -c 4
PING ipv6.google.com(ez-in-x69.1e100.net) 56 data bytes
From b10ict-1-pt.tunnel.tserv11.ams1.ipv6.he.net icmp_seq=1 Destination unreachable: Address unreachable
From b10ict-1-pt.tunnel.tserv11.ams1.ipv6.he.net icmp_seq=2 Destination unreachable: Address unreachable
From b10ict-1-pt.tunnel.tserv11.ams1.ipv6.he.net icmp_seq=3 Destination unreachable: Address unreachable
From b10ict-1-pt.tunnel.tserv11.ams1.ipv6.he.net icmp_seq=4 Destination unreachable: Address unreachable


--- ipv6.google.com ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3004ms

IMCP ping to the WAN port of my router is allowed.
Does anyone know what are wrong?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2701

Are you behind a NAT?  if so, are you passing protocol41?
Logged

rb20

  • readonly_member
  • Newbie
  • *
  • Posts: 3

Yes, i'm behind a NAT. Could you explains what mean with "Are you passing protocol 41?"
Need i forward some port (tcp or udp port 41?) in my router to my Ubuntu server (ip: 192.168.1.10)
(I have currently disabled the firewall on the serverf, but it doesn't matter)
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2701

Two things then

1) When you did the

Code: [Select]
ip tunnel add he-ipv6 mode sit remote 216.66.84.46 local 178.**.50.173 ttl 25

You needed to use your private IP address (eg 192.168.something) instead of your public address of 178...

2) Remember that protocol != port.  Protocol 41 is used for 6in4 and 6to4 tunnels.  Most firewalls will not let you forward a protcol though, so you might be stuck turning off the firewall or placing your host in the DMZ of your router

Try #1 first and go from there
Logged

rb20

  • readonly_member
  • Newbie
  • *
  • Posts: 3

Strange, i have changed the public ip adres to my ip private adres... and it will works!

Code: [Select]

root@ubuntu-serv:~# ping6 ipv6.google.com -c 5
PING ipv6.google.com(ey-in-x68.1e100.net) 56 data bytes
64 bytes from ey-in-x68.1e100.net: icmp_seq=1 ttl=57 time=21.0 ms
64 bytes from ey-in-x68.1e100.net: icmp_seq=2 ttl=57 time=21.2 ms
64 bytes from ey-in-x68.1e100.net: icmp_seq=3 ttl=57 time=35.5 ms
64 bytes from ey-in-x68.1e100.net: icmp_seq=4 ttl=57 time=23.1 ms
64 bytes from ey-in-x68.1e100.net: icmp_seq=5 ttl=57 time=26.4 ms

--- ipv6.google.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4007ms
rtt min/avg/max/mdev = 21.092/25.517/35.586/5.389 ms

Thanks for the quick response ;-)
Logged