Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Can't Ping from Lan interface over IPV6  (Read 2995 times)

zniezelski

  • Newbie
  • *
  • Posts: 2
Can't Ping from Lan interface over IPV6
« on: November 29, 2011, 05:18:51 PM »

I'm a n00b. I setup an IPV6 tunnel on a Cisco router in GNS3 and can ping ipv6.google.com from the command interface of the router.

I am trying to add another interface to the router to attach a host to access the internet through the tunnel over IPV6. I assigned an interface an IP address in my /64 routed prefix (64:2001:470:1f07:15fc::1) and assigned my host (64:2001:470:1f07:15fc::2 using 64:2001:470:1f07:15fc::1 for the gateway) I can ping my Client IPV6 address from the host but I cannot ping the IPV6 address of google from my host. Below is my configuration. Is the address i'm using not routable over the internet? ???
 
fastethernet1/1 is my LAN interface that my host is connected to.

Thanks for your help!

Zach


-------my tunnel information-----
IPv6 Tunnel Endpoints
Server IPv4 Address:209.51.161.14
Server IPv6 Address:2001:470:1f06:15fc::1/64
Client IPv4 Address:71.60.38.46
Client IPv6 Address:2001:470:1f06:15fc::2/64
Available DNS Resolvers
Anycasted IPv6 Caching Nameserver:2001:470:20::2
Anycasted IPv4 Caching Nameserver:74.82.42.42
Routed IPv6 Prefixes
Routed /64:2001:470:1f07:15fc::/64
Routed /48:2001:470:8a78::/48 [X]
rDNS Delegations

---end of tunnel information--

interface Tunnel0
 description Hurricane Electric IPv6 Tunnel Broker
 no ip address
 ipv6 address 2001:470:1F06:15FC::2/64
 ipv6 enable
 tunnel source 192.168.1.110
 tunnel mode ipv6ip
 tunnel destination 209.51.161.14
 !
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
 !
!
interface FastEthernet1/0
 ip address dhcp
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:470:1F07:15FC::1/64
 !
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
nls resp-timeout 1
cpd cr-id 1
ipv6 route ::/0 Tunnel0
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

Router# show run
Building configuration...

Current configuration : 1232 bytes
!
! Last configuration change at 20:05:53 UTC Tue Nov 29 2011
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 description Hurricane Electric IPv6 Tunnel Broker
 no ip address
 ipv6 address 2001:470:1F06:15FC::2/64
 ipv6 enable
 tunnel source 192.168.1.110
 tunnel mode ipv6ip
 tunnel destination 209.51.161.14
 !
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
 !
!
interface FastEthernet1/0
 ip address dhcp
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:470:1F07:15FC::1/64
 !
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
nls resp-timeout 1
cpd cr-id 1
ipv6 route ::/0 Tunnel0
!
!
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

Router#


Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: Can't Ping from Lan interface over IPV6
« Reply #1 on: November 29, 2011, 05:59:00 PM »

I think you're missing a command

Double check it, but I think it's something like "ipv6 unicast routing"
Logged

zniezelski

  • Newbie
  • *
  • Posts: 2
Re: Can't Ping from Lan interface over IPV6
« Reply #2 on: November 29, 2011, 06:20:08 PM »

 :) Hey that was it, thanks a lot!
 
I looked up the command and from what i'm reading, Cisco IOS will not forward IPV6 to the next hop without the command.

from: http://computernetworkingnotes.com/ccna_certifications/routing_with_ipv6.htm

Router(config)# ipv6 unicast-routing
By default, IPv6 traffic forwarding is disabled, so using this command enables it.


Logged