Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Setting Up Virtual Guests to use the routed /64  (Read 4834 times)

lfoothome

  • Newbie
  • *
  • Posts: 14
Setting Up Virtual Guests to use the routed /64
« on: December 23, 2011, 12:00:10 AM »

I have a working Virtualization Host machine Centos 6.2 behind a firewall.  From its terminal I can ping6 ipv6.he.net and have progressed to the Administrator Test. 

What I would like to do is begin using my routed/64 host addresses and give my Virtual Guest Machines IPv6 connectivity. 

Can anyone suggest a good manual or HowTo where this has been done.

The IPv4 bridging is working fine, but entering the addresses manually as routed::1/64 ; routed::2/64 and so forth with a default gateway of Client/64 hasn't been successful.

I'm looking for ideas.  This is an all Fedora/RHEL/Centos setup.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2731
Re: Setting Up Virtual Guests to use the routed /64
« Reply #1 on: December 23, 2011, 05:01:38 AM »

Well, that depends on what you want to accomplish and how you want to accomplish it.   

If you want to assign things manually, I'm sure we can make it work, but we're going to need more information.  If you want to do things dynamically, we can help with that too, but again we need more information.

If you want to do it dynamically, check out Router Advertisements
Logged

lfoothome

  • Newbie
  • *
  • Posts: 14
Re: Setting Up Virtual Guests to use the routed /64
« Reply #2 on: December 23, 2011, 05:06:17 AM »

May have figured this one out.  I'll post how the test goes.

The Client Tunnel Enpoint PC is also the Virtual Host PC.

Will define interface he-ipv6 using RemoteIPv4, LocalIPV4, and Client::2/64 with Client::1/64 as DefaultGateway.

Will assign Routed::1/64 to the bridged eth0-br0 pair with DefaultGateway of Client::2/64.

Will manually assign Routed::2/64 throught Routed::xxxx/64 to Virtual Guests 1 thru xxxx-1 device eth0 respectively DefaultGateway of Client::2/64.

Hoping not to turn on Radvd or RA yet.
Logged

lfoothome

  • Newbie
  • *
  • Posts: 14
Re: Setting Up Virtual Guests to use the routed /64
« Reply #3 on: December 23, 2011, 08:14:19 AM »

well looked like it should have worked but didn't.
VIRTUAL HOST /etc/sysconfig/network-scripts/ifcfg-br0
Quote
DEVICE=br0
TYPE=Bridge
BOOTPROTO=dhcp
ONBOOT=yes
DELAY=0
NM_CONTROLLED=no
IPV6INIT=yes
IPV6ADDR="2001:470:1f11:115d::1/64"
IPV6_DefaultGW="2001:470:1f10:115d::2/64"
VIRTUAL HOST /etc/sysconfig/network-scripts/ifcfg-eth0
Quote
DEVICE="eth0"
NM_CONTROLLED="no"
ONBOOT=yes
HWADDR=00:1D:60:9C:B8:1D
TYPE=Ethernet
NAME="System eth0"
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
BRIDGE=br0
VIRTUAL HOST /etc/sysconfig/network-scripts/ifcfg-he-ipv6
Quote
DEVICE=he-ipv6
BOOTPROTO=none
ONBOOT=yes
IPV6INIT=yes
IPV6_TUNNELNAME=he-ipv6
IPV6_AUTOTUNNEL=yes
PHYSDEV=eth0
IPV6TUNNELIPV4="209.51.181.2"
IPV6TUNNELIPV4LOCAL="192.168.2.201"
IPV6ADDR="2001:470:1f10:115d::2/64"
TYPE=sit
Now on the host ping6 ipv6.he.net works fine

GUEST /etc/sysconfig/network-scripts/ifcfg-eth0
Quote
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=Ethernet
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=yes
IPV6_AUTOCONF=no
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME="System eth0"
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
IPV6_DEFAULTGW=2001:470:1f11:115d::1 ## note 2001:470:1f10:115d::2 and 2001:470:1f10:115d::1 were also tried
IPV6ADDR=2001:470:1f11:115d::3/64
HWADDR=52:54:00:30:E5:9A
PEERDNS=yes
PEERROUTES=yes

Guest /etc/sysconfig/network
Quote
NETWORKING=yes
HOSTNAME=Fedora386Stable
NETWORKING_IPV6=yes

results varied from Network Unreachable to a ping that hung for minutes.

NOTE : HOST Centos 6.2  Guest Fedora 15 both x86_64
Logged

nickbeee

  • tunneld
  • Jr. Member
  • **
  • Posts: 72
  • I do this just for fun.
Re: Setting Up Virtual Guests to use the routed /64
« Reply #4 on: December 23, 2011, 09:17:17 AM »

Do you need to enable IPv6 routing on your Linux distro as you do on the BSD os's?

I've managed to get a similar solution working but with different host and guest under Windows7_64.
  • FreeBSD 8.2 guest on Virtual Box. Bridged interface em0 shares W7 IPv4 LAN connection with it's own ipv4 address.
  • FreeBSD interface gif0 is tunnel to HE using the tunnel /64 over the IPv4 LAN - behind nat - passes protocol41.
  • FreeBSD interface em1 is connected to a host-only network. RTADVD advertises a routed /64 and WIDE-dhcpv6 provides IPv6 DNS servers.
  • Second W7 (host-only) network interface is connected to the above and gets IPv6 address and DNS servers assigned.
  • W7 host is now able to access IPv6 using FreeBSD guest as the router. IPv4 goes via the LAN. 
I could alternatively assign the routed /64 to em0 and advertise IPv6 back out on the LAN for any other hosts to join in. 8)
Logged
Nick B.

Tunnelling with [Open|Net|Free]BSD and IOS.
IPv6 courtesy of   HE and   Sixxs.

Jim Whitby

  • Newbie
  • *
  • Posts: 39
  • Jim Whitby
    • My small piece of cyberspace
Re: Setting Up Virtual Guests to use the routed /64
« Reply #5 on: December 23, 2011, 10:56:57 AM »

IF I understand correctly....

To enable ipv6 tunnel for your VM guests.

Terminate the tunnel in your router ( best) or host (good). Enable radvd.

Enable network bridging on the VM guests.
Enable IPv6 on the guest ( if needed ).

The VM guests will get ipv6 from radvd

I am using the above on Linux host and win7 guest.
To verify the functions on the guest, disable the firewall. Run some checks from remote sites ( ipv6-test.net ) or (/www.tunnelbroker.net/portscan.php). Then for your safety enable the firewall on the guest.
Logged

lfoothome

  • Newbie
  • *
  • Posts: 14
Setting Up Virtual Guests to use the routed /64
« Reply #6 on: December 23, 2011, 01:21:51 PM »

two small changes a restart and it popped to life.
Quote
removed IPV6_DEFAULTGW=2001:470:1f11:115d::1  from GUEST /etc/sysconfig/network-scripts/ifcfg-eth0

added IPV6_DEFAULTGW=2001:470:1f10:115d::2  to GUEST /etc/sysconfig/network

service network restart

DID NOT touch sysctl.conf or enable radvd -- keeping ipv6 local to the box for now.

was also able to remove following from ifcfg-br0 on host and have it keep working after a network restart
Quote
IPV6INIT=yes
IPV6ADDR="2001:470:1f11:115d::1/64"
IPV6_DefaultGW="2001:470:1f10:115d::2/64"

Worked for a short while and then stopped, no rhyme or reason.  More later.
« Last Edit: December 23, 2011, 01:59:11 PM by lfoothome »
Logged