Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: 'Default Gateway' configuration without DHCPv6  (Read 7112 times)

DevNull0

  • Newbie
  • *
  • Posts: 2
'Default Gateway' configuration without DHCPv6
« on: March 08, 2012, 06:18:23 PM »


Greetings :-)

I'm running into a strange issue when I try to use a WinSrv2008-R2 box as my IPv6 router for my home network.  I do not see this issue when I use my usual OpenBSD 5.0 box running rtadvd.

My home network is pretty straight forward, comprising of a bunch of family win7/64 boxes all connected to the net via that OpenBSD box. I have a HE tunnel setup on the OpenBSD box that works fine. All my internal machines can hit ipv6 enabled sites w/o any issues.  I have not configured any static IPv6 addresses on the Win7 boxes nor am I running a DHCPv6 server.  Consequently, the Win7 boxes generate their IPv6 addresses based off of the prefix(es) advertised in the RA.  I also see the 'default gateway' of the Win7 boxes set to the Link-Local address of the internal interface of the OpenBSD box. Furthermore, the OpenBSD box is configured with static IPv6 addresses on it's internal and external NICs.

Most of the above also works when using Win2008-R2 as the router *except* for the default gateway address.  Ipconfig.exe always shows the 'default gateway' value on the Win7 boxes set to '::' no matter what I do on the Win2888-R2 side.  I see no difference even after explicitly publishing both the Link-Local Address or the static IP address of Win2008-R2 box's internal interface as 'default route', like so (publishing and advertising of the 2012:DEAD:BEEF:20::/64 prefix itself works fine and I can see the RAs in WireShark on the Win7 test box, so no firewall issues):

# publish LLA of internal nic as default route
netsh ipv6 add route ::/0 IntNet nexthop=fe80::a56f:74bc:74b2:6fe9 publish=yes

# publish Static IP of internal nic(Prefix: 2012:DEAD:BEEF:20::/64) as default route
netsh ipv6 set route ::/0 IntNet nexthop=2012:DEAD:BEEF:20::1 publish=yes

What am I doing wrong here? Is there something else I need to do to get the (current) Link-local address of the Win2008-R2 box's internal interface show up as the 'default gateway' for the win7 boxes just as it (rightly) happens with rtadvd?

While on the subject, Is it possible to control the frequency of the Win2008-R2 RA messages? Does Win2008-R2 have equivalents for the 'maxinterval' and 'mininterval' config entries from rtadvd.conf?

Thanks for your time!

Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2664
Re: 'Default Gateway' configuration without DHCPv6
« Reply #1 on: March 08, 2012, 06:24:51 PM »

FYI, here are my notes

Code: [Select]
Steps to configure host to act as IPv6 router

1.  In CMD type: netsh int ipv6 set interface IP6Tunnel forwarding=enabled

2.  Next, type: netsh int ipv6 set interface "Local Area Connection" forwarding=enabled advertise=enabled

3.  Next, add the first address of the routed IP address to the Local Area Connection

    netsh int ipv6 add address "Local Area Connection" 2001:db8:8:a0a::1

4.  Next, add the default route and next hop for the tunnel and Local Area Connection, then publish it:

    netsh int ipv6 set route 2001:db8:8:a0a::/64 "Local Area Connection" publish=yes

5.  Next, add the default route for the tunnel and publish it:

    netsh interface ipv6 set route ::/0 IP6Tunnel 2001:db8:7:a0a::1 publish=yes
Logged

DevNull0

  • Newbie
  • *
  • Posts: 2
Re: 'Default Gateway' configuration without DHCPv6
« Reply #2 on: March 08, 2012, 11:22:13 PM »


Thanks for the quick response!

I was missing the explicit enabling of forwarding on the internal side (part of the command in step 2 in your notes)... I'd assumed it was implied by the fact that I was publishing a prefix.

Thanks again!
Logged