Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: DNS verifiaction test  (Read 3471 times)

revenuewire

  • Newbie
  • *
  • Posts: 2
DNS verifiaction test
« on: July 18, 2012, 02:53:52 PM »

Hi,

I found a very strange issue with the DNS test to master the level guru.
I set up the subdomain he-test within my namespace but don't even receive a query for that name if I execute the test.
To be sure I tried serveral DNS (google etc.) to verify I'm able to handle DNS requests via IPv6.

Here is what I did:

dig +trace he-test.revenuewire.com AAAA @2001:4860:4860::8888

; <<>> DiG 9.7.3 <<>> +trace he-test.revenuewire.com AAAA @2001:4860:4860::8888
;; global options: +cmd
.         1766   IN   NS   g.root-servers.net.
.         1766   IN   NS   c.root-servers.net.
.         1766   IN   NS   b.root-servers.net.
.         1766   IN   NS   h.root-servers.net.
.         1766   IN   NS   d.root-servers.net.
.         1766   IN   NS   e.root-servers.net.
.         1766   IN   NS   j.root-servers.net.
.         1766   IN   NS   m.root-servers.net.
.         1766   IN   NS   i.root-servers.net.
.         1766   IN   NS   k.root-servers.net.
.         1766   IN   NS   f.root-servers.net.
.         1766   IN   NS   a.root-servers.net.
.         1766   IN   NS   l.root-servers.net.
;; Received 228 bytes from 2001:4860:4860::8888#53(2001:4860:4860::8888) in 121 ms

com.         172800   IN   NS   h.gtld-servers.net.
com.         172800   IN   NS   d.gtld-servers.net.
com.         172800   IN   NS   l.gtld-servers.net.
com.         172800   IN   NS   k.gtld-servers.net.
com.         172800   IN   NS   f.gtld-servers.net.
com.         172800   IN   NS   g.gtld-servers.net.
com.         172800   IN   NS   m.gtld-servers.net.
com.         172800   IN   NS   c.gtld-servers.net.
com.         172800   IN   NS   a.gtld-servers.net.
com.         172800   IN   NS   e.gtld-servers.net.
com.         172800   IN   NS   j.gtld-servers.net.
com.         172800   IN   NS   i.gtld-servers.net.
com.         172800   IN   NS   b.gtld-servers.net.
;; Received 497 bytes from 192.33.4.12#53(c.root-servers.net) in 104 ms

revenuewire.com.   172800   IN   NS   ns1.revenuewire.com.
revenuewire.com.   172800   IN   NS   ns2.revenuewire.com.
revenuewire.com.   172800   IN   NS   ns3.revenuewire.com.
;; Received 143 bytes from 2001:503:231d::2:30#53(b.gtld-servers.net) in 207 ms

he-test.revenuewire.com. 900   IN   AAAA   2001:470:eac1:2:1:1:1:5
revenuewire.com.   900   IN   NS   ns2.revenuewire.com.
revenuewire.com.   900   IN   NS   ns1.revenuewire.com.
revenuewire.com.   900   IN   NS   ns3.revenuewire.com.
;; Received 255 bytes from 2001:1af8:4300:a005:49::1#53(ns3.revenuewire.com) in 196 ms

So it shows me that the answer came from ns3 via IPv6, with tcpdump I've confirmed that I've sent the query via IPv6 as well.

23:46:47.605838 IP6 2001:470:b:943:xxxx:xxxx:xxxx:xxxx.45600 > 2001:1af8:4300:a005:49::1.53: 61972 AAAA? he-test.revenuewire.com. (41)
I did the same test with several other ns in Europe with exact the same result.
Everything looks to me like it is working, did anyone come across a similar issue.

I suppose the next step is to bug them and ask, the only error they show on their website is Couln't query NS, which doesn't really help me find out if I still have an issue somewhere.

Thx in advance.
Logged