Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: IP6 Tunnel Configuration Help  (Read 5612 times)

Yoshi321

  • Newbie
  • *
  • Posts: 4
IP6 Tunnel Configuration Help
« on: August 03, 2012, 03:22:24 PM »

Hi everyone. So after I configured the IP6 Tunnel, I tried to ping the Default Gateway, but received a "general failure" response. Before doing this, I entered in the following commands into the command prompt,
Code: [Select]
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel 192.168.1.2 72.52.104.74
netsh interface ipv6 add address IP6Tunnel 2001:470:1f04:7e1::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f04:7e1::1
I changed the first ip address of the second line which was originally my public ip to my private ip.

Here is my IP Configuration for my Wireless Adapter and IP6 Tunnel:
Code: [Select]
Wireless LAN adapter MAIN RECEIVER:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Dual Stream 802.11n Wireless LAN Card
   Physical Address. . . . . . . . . : D0-DF-9A-85-BF-C5
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::e8b3:2179:97dd:a1d%14(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, August 03, 2012 12:22:58 PM
   Lease Expires . . . . . . . . . . : Saturday, August 04, 2012 12:22:58 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 265346970
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-5F-A2-3E-38-60-77-67-DD-F7

   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled


Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Direct Point-to-point Adapater
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::59a7:4c94:fa9f:ca1c%32(Preferred)
   Default Gateway . . . . . . . . . : 2001:470:1f04:7e1::1
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Here is the error when I ping (the same goes for all other ipv6 addresses):
Code: [Select]
Pinging 2001:470:1f04:7e1::1 with 32 bytes of data:
General failure.
General failure.
General failure.
General failure.

Ping statistics for 2001:470:1f04:7e1::1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

While I was reading around the forum, I also discovered that protocol 41 must be allowed through the firewall (I use Windows 7 Firewall). I do not know if I configured it correctly, but I set a new inbound rule with Protocol Type IPV6 which automatically changed the protocol number to 41. This rule is set to always allow.

My Netgear Router (model WRN1000v2) is port forwarding port 41, and is checked to "Respond to Ping on Internet Port ." I have no evidence to say this, but I think my router has a compatibility issue.

Something else to know is that I followed instructions from this site: http://www.cellstream.com/intranet/tipsandtricks/250-setting-up-a-6to4-tunnel-in-windows-7.html

Overall, I would like to know what I am doing wrong or if I missed anything. If you need more information please tell me.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2671
Re: IP6 Tunnel Configuration Help
« Reply #1 on: August 03, 2012, 06:43:22 PM »



Keep in mind that forwarding port 41 on your router isn't doing anything...do you have  a dmz mode?

I have a hunch that seeing dmz mode won't work, but we need to rule it out
Logged

Yoshi321

  • Newbie
  • *
  • Posts: 4
Re: IP6 Tunnel Configuration Help
« Reply #2 on: August 03, 2012, 09:39:25 PM »



Keep in mind that forwarding port 41 on your router isn't doing anything...do you have  a dmz mode?

I have a hunch that seeing dmz mode won't work, but we need to rule it out

Okay, I took out the port forward for port 41, and yes, I do have a dmz mode, but it is unchecked. It only lets me put a 192.168.1.XXX address into it.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2671
Re: IP6 Tunnel Configuration Help
« Reply #3 on: August 04, 2012, 10:42:52 AM »

You should put the ipv4 address of your tunnel server in the dmz mode
Logged

Yoshi321

  • Newbie
  • *
  • Posts: 4
Re: IP6 Tunnel Configuration Help
« Reply #4 on: August 04, 2012, 02:44:06 PM »

You should put the ipv4 address of your tunnel server in the dmz mode

I did that and this is what I got, "The IP address should be in the same subnet as the LAN IP address."
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2671
Re: IP6 Tunnel Configuration Help
« Reply #5 on: August 05, 2012, 07:49:16 AM »

It looks like we set something wrong somewhere

http://forum1.netgear.com/showthread.php?t=71276
Logged

Yoshi321

  • Newbie
  • *
  • Posts: 4
Re: IP6 Tunnel Configuration Help
« Reply #6 on: August 12, 2012, 04:29:02 PM »

Nevermind, I was able to get it working. I just had to reset my adapter and run the set up again from the very start. Thanks anyways.
Logged