• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Delegate rDNS to afraid

Started by marins82, November 05, 2012, 02:57:41 AM

Previous topic - Next topic


I afraid to delegate rDNS to get the vhost on ipv6
I put the domain name on afraid of the tunnel:
2001:470:27:2 e4 :: / 64 and delegate a
subdomain, based on the addresses / 64 of the
tunnel. But it does not work, for the powers of
the tunnel must spend a lot of time?


You cannot delegate or change rDNS PTR records for the tunnel's point-to-point /64 allocation. Try using your routed /64 or /48. domain name pointer marins82-1.tunnel.tserv24.sto1.ipv6.he.net. domain name pointer marins82-1-pt.tunnel.tserv24.sto1.ipv6.he.net.


I try ipv6/64 routed at 2001:470:28:2e4::/64
but not work...


Explain, in great detail, what you meant/did by "try".


I put the ip ipv6 routed afraid of 2001:470:28:2
e4 :: / 64, creating the subdomain 2001:470:28:2
e4 :: aa, updated bnc but I get the vhost!


Not that I give a fork about IRC, but you know you need matching forward and reverse for that to work right? Do you have matching forward records to your reverse? Also the Afraid name servers aren't returning any PTR record for 2001:470:28:2e4::aa 10800 IN      NS      NS2.HE.NET. 10800 IN      NS      NS3.HE.NET. 10800 IN      NS      NS1.HE.NET. 10800 IN      NS      NS5.HE.NET. 10800 IN      NS      NS4.HE.NET.
;; Received 186 bytes from 2001:500:13::63#53(2001:500:13::63) in 81 ms

4.e. 4900 IN NS ns1.afraid.org.
4.e. 4900 IN NS ns2.afraid.org.
4.e. 4900 IN NS ns3.afraid.org.
4.e. 4900 IN NS ns4.afraid.org.
4.e. 4900 IN NS ns5.afraid.org.
;; Received 190 bytes from 2001:470:400::2#53(2001:470:400::2) in 348 ms

;; Received 90 bytes from 2607:f0d0:1102:d5::2#53(2607:f0d0:1102:d5::2) in 40 ms

Direct queries come back as REFUSED:

dig -x 2001:470:28:2e4::aa @ns1.afraid.org.

; <<>> DiG 9.8.1-P1 <<>> -x 2001:470:28:2e4::aa @ns1.afraid.org.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 10869
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;a.a. IN PTR

;; Query time: 42 msec
;; SERVER: 2607:f0d0:1102:d5::2#53(2607:f0d0:1102:d5::2)
;; WHEN: Mon Nov  5 12:55:28 2012
;; MSG SIZE  rcvd: 90


I have a similar problem, too. Reverse DNS doesn't work for my /64 as well.
I've set these nameservers on HE website:

And reverse lookup still doesn't work. I thought it was related to DNS caches, but a whole day passed already.

[b]wolfman% host pi.xtsubasa.org[/b]
pi.xtsubasa.org has IPv6 address 2001:470:28:3a3::4

[b]wolfman% host 2001:470:28:3a3::4[/b]
Host not found: 3(NXDOMAIN)

[b]wolfman% host 2001:470:28:3a3::4 ns1.afraid.org[/b]
Using domain server:
Name: ns1.afraid.org
Aliases: domain name pointer pi.xtsubasa.org.


I'd send HE an email to make certain delegation is set on their side. Might be it didn't take the update for some reason, or there are stale rDNS zones in the dns.he.net service or something.


I decided to go with ns*.he.net servers and still had trouble adding records on the webpage. I emailed the staff then and they fixed it.