Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  


Welcome to Hurricane Electric's forums!

Author Topic: add new domain  (Read 2991 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
add new domain
« on: May 17, 2013, 03:15:40 AM »


I try to add a subdomain for use with dynamic DNS. I delegated a subdomain to HE DNS server, but I cannot add it.

Code: [Select]
kroerig@hosting01:~$ dig NS

; <<>> DiG 9.8.1-P1 <<>> NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43974
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 0

;         IN      NS

;; ANSWER SECTION:  86400   IN      NS  86400   IN      NS  86400   IN      NS  86400   IN      NS  86400   IN      NS

;; Query time: 129 msec
;; WHEN: Fri May 17 12:12:51 2013
;; MSG SIZE  rcvd: 117

Error message:
Zone failed validation test. ERROR: Delegation was not found. Please delegate to ns1, ns2, ns3, ns4 and then retry. ( /

Bug or works as designed?



  • Founder, Netiter ApS
  • Hero Member
  • *****
  • Posts: 952
    • View Profile
Re: add new domain
« Reply #1 on: May 17, 2013, 03:23:12 PM »

Bug or works as designed?
I think your delegation configuration looks strange. You do have NS records for the subdomain, but and still consider themselves authoritative for the subdomain.

So when trying to lookup, the following happens:
  • The gtld servers, which are authoritative for com delegates to and
  • Recursive resolver queries or
  • does not delegate to HE, but instead replies with an authoritative NXDOMAIN response.

When doing dig -t any I get a response with not just your NS records, but also a SOA record indicating is authoritative. Maybe you need to fix that SOA record, to make it work.