• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.


Welcome to Hurricane Electric's Tunnelbroker.net forums!

Main Menu

Stuck on Guru test

Started by mattwilson9090, June 02, 2013, 03:15:38 PM

Previous topic - Next topic


I'm stuck on the Guru level tests. The problem is I *think* I've got everything configured properly, but since the results are only a general messages and not the detailed results I'm not sure where to look.

At this point I'm assuming that I've got something misconfigured that will be obvious once I know what it is, or I'm just not waiting long enough for TTL's to expire.

My registered domain is brightstarconsulting.com, and for these tests I've been using a subdomain of ipv6.brightstarconsulting.com. My domain registrar is GoDaddy, and among other things they are hosting DNS. rDNS for IPv6 is handled by HE's DNS service. Website and email server for IPv6 testing is on a server I setup for these tests that's here locally.

I get the same results when I try the test for ipv6.brightstarconsulting.com and brightstarconsulting.com when I try the first test "Check to see that the nameservers associated with brightstarconsulting.com have IPv6 AAAAs". The results I get back are "Couldn't find any nameservers for brightstarconsulting.com or no AAAA records found for NS
If this is a subdomain, edit to primary domain in the step #1 and retest" (the second part is the reason I've also tested on my full domain rather than the subdomain).

I've got several AAAA records configured in my DNS. I would have thought that was sufficient for the test. Is it possible that the test is looking for some other AAAA records, such as the AAAA records for the NS itself (ns71.domaincontrol.com and ns72.domaincontrol.com)? If that's the case I either need to change my GoDaddy nameservers for other GoDaddy ones that have AAAA records, or I need to change to completely different nameservers, such as the ones hosted by HE.

No, I just checked by a quick ping of the FQDN of the nameservers and it tried to ping IPv6 addresses, so now I'm really not sure where to look.

I haven't even tried to follow up with the second Guru test since I figure that will keep failing while the first one is.

Can anyone offer me any insight or areas to further look at?
Matt Wilson


As a follow up, after finding another post in this forum that discussed this same issue and showed the dig commands he used I did the same thing, only substituting the information for my domain rather than this, and it appears that I got comparable information.

The solution to his problem was that HE needed to flush the cache, though they also asked about TTL. It's possible that I may be within the TTL still, though I'm not exactly adept with interpreting all of the results from dig.
Matt Wilson


Well, it's been several days and still no change. It's been enough for several TTL's to elapse by now. The only other thing I can think of is to email HE and ask them to flush the cache.

Does anyone else have any other ideas?
Matt Wilson


I see the first mx record pointing to smtp.secureserver.net. The authoritative DNS servers for secureserver.net have both IPv4 and IPv6 addresses, but all requests to their IPv6 addresses time out.