Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Stuck on Guru test, not my fault!  (Read 4728 times)

Salamihawk

  • Newbie
  • *
  • Posts: 2
Stuck on Guru test, not my fault!
« on: June 24, 2013, 12:04:37 PM »

Hi everyone,

I'm stuck on the Guru test but I don't think it's my fault... the web and mail server I used for the other tests is IPv6 enabled and reachable, but I got IPv6 because I volunteered to be part of a test rollout with the provider that hosts my server and domain.

That means that, even though their IPv6 network is online, their DNS servers are still on vanilla IPv4 and do not have AAAA records. Since I don't own those servers, I'm unable to change what's in their DNS records... So what does that mean? I can't get past Guru?

Code: [Select]
dig ns huttnet.com

; <<>> DiG 9.7.3 <<>> ns huttnet.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44536
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;huttnet.com.                   IN      NS

;; ANSWER SECTION:
huttnet.com.            1038    IN      NS      dns2.ispone-business.de.
huttnet.com.            1038    IN      NS      dns1.ispone-business.de.
Code: [Select]
dig aaaa dns1.ispone-business.de.

; <<>> DiG 9.7.3 <<>> aaaa dns1.ispone-business.de.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31923
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;dns1.ispone-business.de.       IN      AAAA

;; AUTHORITY SECTION:
ispone-business.de.     300     IN      SOA     dns1.dns-on.de. hostmaster.dns-onde. 2008111006 10800 1800 604800 300

;; Query time: 1 msec
;; SERVER: 193.151.6.201#53(193.151.6.201)
;; WHEN: Mon Jun 24 21:04:21 2013
;; MSG SIZE  rcvd: 108
Logged

Salamihawk

  • Newbie
  • *
  • Posts: 2
Re: Stuck on Guru test, not my fault!
« Reply #1 on: June 24, 2013, 12:58:48 PM »

I may have found a workaround. I have set up HE DNS servers as slaves to my domain and placed them in the DNS Zone, just gotta wait for the TTL to expire to see if it works...

Edit: It worked! Now just gotta figure out what to do about the glue...
« Last Edit: June 24, 2013, 01:19:02 PM by hurricanelocust »
Logged