Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Trouble on my MacBook (10.8.4)  (Read 6132 times)

btrosper

  • Newbie
  • *
  • Posts: 1
Trouble on my MacBook (10.8.4)
« on: July 19, 2013, 05:17:03 PM »

I've got a vexing problem that I've been poking at all evening, and I'm stumped.  At the same time, I miss my IPv6 on my laptop...so I'm hoping someone out there can help me.

My MacBook is on a router with the local address 192.168.1.82 (Ethernet connection, WiFi is off).  IPv6 is enabled on my router, and it's not firewalling or filtering anything that would interfere with the tunnel (as I have a separate tunnel working on a Win7 machine on the same subnet...it's 192.168.1.106)...so it's a safe bet the router isn't a factor here.

So, before I get started, let me prove that before creating the tunnel, the computer isn't v6 capable (all commands are being run as sudo):

Quote
sh-3.2# ping6 ipv6.google.com
ping6: UDP connect: No route to host

No surprises here.  There's no route to do any v6 pinging.  So now, I set up the tunnel with my endpoint in Dallas (216.218.224.42) as per the instructions:

Quote
sh-3.2# ifconfig gif0 create
sh-3.2# ifconfig gif0 tunnel 192.168.1.82 216.218.224.42
sh-3.2# ifconfig gif0 inet6 2001:470:1f0e:d44::2 2001:470:1f0e:d44::1 prefixlen /64
sh-3.2# route -n add -inet6 default 2001:470:1f0e:d44::1
add net default: gateway 2001:470:1f0e:d44::1

So, this seems to have gone well.  Let's have a look at the gif0 segment of ifconfig:

Quote
gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
   tunnel inet 192.168.1.82 --> 216.218.224.42
   inet6 fe80::3e07:54ff:fe28:1a47%gif0 prefixlen 64 scopeid 0x2
   inet6 2001:470:1f0e:d44::2 --> 2001:470:1f0e:d44::1 prefixlen 128

Looks like it should work, and at this point in the past it always did.  However, this is now the result:

Quote
sh-3.2# ping6 ipv6.google.com
PING6(56=40+8+8 bytes) 2001:470:1f0e:d44::2 --> 2607:f8b0:4000:804::1010

--- ipv6.l.google.com ping6 statistics ---
10 packets transmitted, 0 packets received, 100.0% packet loss

What I'm having trouble understanding is that it's able to resolve ipv6.google.com, but not ping it.  So clearly there is some ability to communicate over v6, but that doesn't appear to extend to ping or other traffic.  There's a similar disaster using traceroute6:

Quote
sh-3.2# traceroute6 ipv6.google.com
traceroute6 to ipv6.l.google.com (2607:f8b0:4000:804::1010) from 2001:470:1f0e:d44::2, 64 hops max, 12 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *

Based on some threads I've seen on this forum, I have tried changing this line:
Quote
ifconfig gif0 inet6 2001:470:1f0e:d44::2 2001:470:1f0e:d44::1 prefixlen /64
to this:
Quote
ifconfig gif0 inet6 2001:470:1f0e:d44::2 2001:470:1f0e:d44::1 prefixlen /128
...but the end result is the same.

I've been using Tunnel Broker for years without any issue on this MacBoook, and suddenly it's failing.  I have double checked that the IPv4 endpoint for my tunnel is correct, so that's not the issue.  It just seems like as of last week I cannot get the tunnel to work no matter what I do (or which location I use).

I can resolve IPv6 addresses and get the proper FQDN (you'll notice the traceroute goes to ipv6.l.google.com and not ipv6.google.com) but not ping them.   ???

Can anyone help me understand what I'm doing wrong?  I assume I'm doing something stupid, but I cannot seem to figure it out.

Thank you very much for taking the time to read (and hopefully respond).
Logged

kasperd

  • Founder, Netiter ApS
  • Hero Member
  • *****
  • Posts: 965
Re: Trouble on my MacBook (10.8.4)
« Reply #1 on: July 20, 2013, 12:24:01 AM »

IPv6 is enabled on my router, and it's not firewalling or filtering anything that would interfere with the tunnel (as I have a separate tunnel working on a Win7 machine on the same subnet...it's 192.168.1.106)...so it's a safe bet the router isn't a factor here.
Several problems right there. First of all if IPv6 is really enabled and working on the router, you shouldn't have any need for tunnels on individual devices in the first place. Each of them should just be getting an announcement from the router and autoconfigure.

Secondly if you still want tunnels on individual devices, keep in mind that multiple tunnels through one NAT is not supported. Even if the NAT could handle it, HE have restrictions in place to prevent you from doing it.

To have a chance of getting two tunnels working through a single NAT you have to
  • Pick a NAT device which can handle it.
  • Configure the tunnels through different tunnel providers.
  • Ensure none of your tunnel endpoints recognizes 6to4 addresses and handle them efficiently.

I think you'd get a better result by running one tunnel on the router itself, and let it announce a prefix to the LAN.
Logged

lamparskysystems

  • Newbie
  • *
  • Posts: 1
Re: Trouble on my MacBook (10.9)
« Reply #2 on: December 02, 2013, 03:09:59 AM »

sorry guys i cant help my self , i need to use ipv6 on my pc can anyone show me how to do that os 10.9


Matt
Logged