Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Problem with ipv6 in XP SP3  (Read 3482 times)

terryipvsix

  • Newbie
  • *
  • Posts: 4
Problem with ipv6 in XP SP3
« on: August 11, 2013, 03:24:32 PM »

I have tried for months to get this working on xp and failed.

I have a home network behind a FiOS router I don't know if protocol 41 is being passed but my linux box works perfectly as does the Mac, just the two xp systems do not ping any ipv6 addresses externally.  I can ping6 all the other computers in the network from any box but the xp systems will not ping ipv6.google.com nor any ipv6 address.  I believe the internal ping works because I have radvd running on the linux box so it assigns ipv6 addresses to everything.  I have tried turning off radvd with no change to the external access but no more local pinging.  I have tried running the xp system without the linux box running and get no access.  I have tried the example commands for both win xp and vista with no access.  Also using the local ipv4 address as an end point instead of the FiOS ipv4 endpoint but no difference.  I do get a change in the response to a ping of either "Timed out" or "Destination address unreachable"  but since I change too many things in between I'm not sure what changes produced this.  I have seen both responses in the same ping.  I have tried removing the ipv6 service then reinstalling it because I'm not sure if all my different settings are messing up the routing in windows.  I tried to stop Teredo but I get messages that the command is not found but ipconfig doesn't show a Teredo route.  I used a command that was suppose to show if the router was blocking the NAT or the NAT wasn't compatible with xp but it showed good but I forget what the command was.  I understand that xp will try to use ipv4 addresses over ipv6 if it finds them but ping6 should override this.

I have run out of ideas on what to try next and am hoping someone has some ideas.  It seems that xp can be used with this tunnel as others seems to have done it.
Logged

allen4names

  • Newbie
  • *
  • Posts: 48
Re: Problem with ipv6 in XP SP3
« Reply #1 on: August 13, 2013, 06:31:23 PM »

The following command works using Ubuntu Precise.
Code: [Select]
sudo traceroute -P 41 tserv1.sea1.he.net
Use the FQDN or IPv4 address of your tunnel endpoint if it is different from the example above.
Logged

terryipvsix

  • Newbie
  • *
  • Posts: 4
Re: Problem with ipv6 in XP SP3
« Reply #2 on: August 13, 2013, 11:12:11 PM »

I believe I solve it but am not really sure what I did.  If someone could explain what happened and/or what the commands did I would very much appreciate it and them.  I know some of this is in Linux and this is a windows section but it all inter-relates.
What I did:
I found a description of setting up a redhat system with ipv6 and saw that to make it automatic they had the line IPV6TO4INIT=yes.
I don't want automatic so I removed that line and added an address with IPV6ADDR=2001:470:e:dee::3/64 (the routed ipv6 prefix given to my tunnel and putting the 3 at the end)
next I added "net.ipv6.conf.all.forwarding=1" to sysctl
then in radvd add the same prefix but left it as given "2001:470:e:dee::/64"
and add the line "AdvRouterAddr on"

Also I used the example commands from the vista/win7 example not the xp example and used my end point ipv4 address not the machine NAT given address as suggested everywhere.
windows now will ping6 everything and firefox will access ipv6 addresses.

It did all start to work after I manually added the address to the wlan0 config file.  Not sure why that would be.
« Last Edit: August 15, 2013, 05:11:17 AM by terryipvsix »
Logged