• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

The D-Link DIR-615 Hardware Rev.: C1

Started by broquea, December 09, 2008, 04:51:58 PM

Previous topic - Next topic


Quote from: bassin on March 23, 2010, 08:39:00 PM
Broquea, you are right, my dir-615 ip address is provided by my adsl modem, but that ip is so I think I understand where the wrong configuration is, I must use the ip that the modem assigns to the router not the local network ipv4 address. I will try it and check the Nat of the modem. ;D ;D

I will post the results thanks for the help

Since the WAN interface of the router must be pingable by the tunnel server, using 1918 addressing would break that. What an interesting twist!

One of the things I had to do with the 615 was to put in a filter to allow the tunnel server to ping the WAN interface, since by default response to ping is disabled.

So Bassin, please do post back what your results were.


I found that putting my DSL modem into "bridge mode" (thus turning off its router and DHCP functions) was what was necessary to pass through the offered IP to the 615's WAN port.  Maybe that's what you need to do as well.


Probably the best bet for anyone who has a decent router, since it'll likely be better than the one in your DSL modem.


Just wanted to add that I have a DIR-825 B1 (EU fw), while it doesn't display any IPv6 logos on the box there is IPv6 support. I currently have IPv6 over wired and wireless :D


Quote from: broquea on December 09, 2008, 09:40:54 PM
So the DIR-615-SWs at Fry's were all rev B2

Look for the not "SW" model just the DIR-615, all the ones there were all opened, and returned, they had nothing wrong with the 2 I bought.

The revision is on the bottom of the box with the S/N etc.

Are the DIR-615-SW's not the same hardware as the  DIR-615? I have an SW that has hardware ver C1, so I think DD-WRT will work on it. But just to make sure, I googled it, and this is the only place on the internet that might lead me to think otherwise.


Quote from: ericisshort
Are the DIR-615-SW's not the same hardware as the  DIR-615? I have an SW that has hardware ver C1, so I think DD-WRT will work on it. But just to make sure, I googled it, and this is the only place on the internet that might lead me to think otherwise.

I'm looking at my box right now, and there is no -sw. There isn't even an IPv6 Ready sticker on it.


Thanks for the quick reply. My packaging does have the IPv6 ready logo on it. Is that a bad thing for the compatibility?

I finally took the router out of the box, and the device has DIR-615 (without SW) on it. That leads me to believe that they are the same base product. I can only assume that the SW must relate to the anti-virus/anti-spyware software package that is advertised on the box.


That's easy, don't use 2002. Use your routed /64.



Quote from: bassin on March 23, 2010, 06:30:10 PM

I'm new to ipv6, and I'm triing to set up my first home tunnel, first I updated my dir-615 firmware to version 3.11NA, then I followed all the posts I finded in the forrum but without sucess my configuration is this one:

Server IPv4 address:
Server IPv6 address:    2001:470:7:5c6::1/64
Client IPv4 address:    189.xxx.xxx.21
Client IPv6 address:    2001:470:7:5c6::2/64

inside dlink ipv6 setup I did the configuration in the picture attached, I'm using windows seven with an wireless adapter, in the details page I can see the ipv6 ip and the gateway that is the same as the Server IPv6 address, the dns I had to setup it manualy and used the one provided by tunnelbroker. when I trie to access the internet windows report that there is no connection and when I ping some ipv6 adress inside the router I can do it.

Any advice? I'm almost giving up...

The reason you had to configure the DNS server manually is because the D-Links don't hand out IPv6 DNS server IPs on their LAN interface.  In a packet capture I see the WAN interface (configured for SLAAC) requesting and receiving it via stateless DHCP, but it doesn't show in the GUI.



Guys, help me please...

I bought a D-LINK DIR-615 and updated with the latest firmware.
I configured the IPv6 over IPv4 tunnel to HE Tunnel Broker, but I can't connect to IPv6 web sites.

My revision is E4 and firmware 5.11.

On IPv6 setup:
My IPv6 Connection is : IPv6 over IPv4 Tunnel
Remote IPv4 Address :
Remote IPv6 Address : 2001:470:xx6x:xxxx::1 (I changed my real numbers to xxxx)
Local IPv4 Address : xxx.xxx.xxx.xxx (This is my valid IP and it's fixed by d-link, I can't change)
Local IPv6 Address : 2001:470:xx6x:xxxx::2
Primary IPv6 DNS Server : 2001:470:20::2
LAN IPv6 Address : 2001:470:xx7x:xxxx::1 / 64 (The /64 is in a separated text box)
Autoconfiguration Type : SLAAC + Stateless DHCPv6
Router Advertisement Lifetime: 1440 minutes

On status:

IPv6 Connection Type :   IPv6 over IPv4 Tunnel
Network Status :   Disconnected
WAN IPv6 Address :   None
IPv6 Default Gateway :   none
LAN IPv6 Address :   2001:470:xx7x:xxxx::1/64
LAN IPv6 Link-Local Address :   fe80::218:e7ff:feec:3b6f/64
Primary IPv6 DNS Server :   None
Secondary IPv6 DNS Server :   None
DHCP-PD :   Disabled


Fernando Hara


We can't help you if you x out all of your ip addresses.  Please replay with the actual information


Hello, I might be with the same problem as netcallcenter.

I am using one DIR-615 Rev. C1 with firmware 3.12NA (3.13NA do not work, the router is unable to connect with the tunnel. The web-interface don't save setting for the "Local IPv6 Address")

The computer receive one IPv6 address, but the internet do not work. Tested on Windows Vista and on Ubuntu 10.04.

On picture of my configuration:


Pretty sure :1f1e: isn't your routed /64


Quote from: broquea on May 01, 2011, 02:45:32 PM
Pretty sure :1f1e: isn't your routed /64

Oops, thanks.

I changed the "LAN IPv6 Address" to 2001:470:1f0f:b26:: (Routed IPv6 Prefix, as shown here on this site), the interface gave me one error saying it was an illegal address, tried 2001:470:1f0f:b26::0 and it accepted the address, but the internet is still not working :/

I am able to ping 2001:470:1f0e:b26::2, but if i ping 2001:470:1f0e:b26::1 I get "Destination Host Unreachable".