• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Uverse RG upgrade - no protocol 41

Started by digitalgoat, August 13, 2013, 07:07:56 AM

Previous topic - Next topic


After a recent firmware update of my Uverse VDSL modem/residential gateway, 6in4 tunnels no longer work. This seems to be a result of implementation of IPV6 in firmware Even though ipv6 is un-configurable and there seems to be no pass through for protocol 41, I may try to check with a static  ip block routed to the unit as I think the issue may be that my IPV6 router is sharing the public IP of the RG. Anyone have similar experiences?


How did you have your RG and tunnel setup?  Was the RG configured with router-behind-router enabled, or just doing it as a DMZ host?  Curious as I'm configured with router-behind-router, and have a working tunnel.  No idea what the firmware is at the moment, since I haven't plugged directly into the RG to check recently.


I believe that the router-behind-router setting was introduced in the new firmware (I've read that ATT started pushing it sometime around March). I'm setting my 7204vxr static to the public address of the RG, which has caused some strangeness, but has worked overall. Do you have an additional /28 with your service? I'm going to try the router-behind-router and see where that takes me.


I have tried several options to get it to work as well on my 3801 with the new firmware.  I have even gone as far as to email customer care to get them to enable IPv6 for me.  (Which at last play was horrible as I could not reach anything inside, the /60 they gave out, from a he.net tunnel elsewhere.  Any trace out would result in exactly 9 hops, first and last being the only responses in ping.)

An older thread on DSLReports before yours, dont know if you saw it, covered most of the problem already.  The consensus seemed to me that the modem/router/pos is "eating" the protocol.

A post in dsl direct resulted in this on the 10th of July via "David"
ok, long story short this is a confirmed problem with the new firmware. It's on the known issues board, and at this time there is no ETA as to when it will be repaired. 2wire/pace is still investigating and that was as of earlier today.

I haven't had anyone try any of these possible theory points yet as a fix. Keep in mind my thoughts currently? Keep in mind these are untested/unconfirmed theories on possible ways around the problem for the moment.

1.) would the he.net tunnel work if the "cascaded router" option was used?

2.) downgrading to a 2wire 3800- I believe this model didn't get a firmware update, which (in a sense) should still allow you to do what you want.

I have not had time to test the cascaded router option out and I would rather not go backwards in modem versions right now.  (No sense in fixing whats "broke").  My solution was to purchase a 3rd party vpn solution and have my router connect to that and route my tunnel over that.  Horrible I know but I have been meaning to get a 3rd party vpn for some testing reasons of my own anyway.


I read the same post earlier today. I even went as far as getting a static address block to see if it would bypass the 2wires need to attempt to terminate locally (I suspect), but ATT support couldn't provision correctly. I finally gave up and now have it terminated on my much slower DSL link.


Looks like the 3800s are getting updates.

I now have no IPv6 at home.  Oh, the irony.


I can also confirm that protocol 41 is blocked in, even with a static IP block.  I was running an HE.net tunnel with my Cisco 2811 assigned one of the static registered IPs in my block, and it quit working the same as everyone else when the firmware was updated.

There is one more configuration option I'm going to try that's new in the U-Verse router's new firmware, but I don't have high hopes.


Same problem here with a 3800HGV-B that was recently forced a reboot causing it to get after which I do have an IPv6 tab in the router settings which is marked as disabled and after which IPv6 tunneling no longer works from my machine.

??? So they give our firmware IPv6 capability, but keep it disabled and undeployed breaking whatever IPv6 work-around we had in the mean time... smooth... very smooth...


Many other AT&T DSL users are reporting the same problem.  So far, there is no solution (unless one can downgrade to an earlier version of the firmware).  I suggest you add yourself to the masses who are bugging AT&T about this bonehead decision.


I have confirmed that DMZ plus option does not work. Would having my own ADSL2+ modem fix this? Does TWC have this problem?