Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: DNS Delegation Dig Fails  (Read 2286 times)

keyoke

  • Newbie
  • *
  • Posts: 3
DNS Delegation Dig Fails
« on: November 25, 2014, 02:29:59 AM »

Hi,
I have added domains my but one of my domain registrars uses "dig @ns1.he.net domain.co.za ns" as pre-check before switching nameservers. they are getting a timeout as below so I cant change my nameservers, have I setup my domain incorrectly on he?

; <<>> DiG 9.9.2-P2 <<>> @NS1.HE.NET domain.co.za ns
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached

Thanks
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1717
Re: DNS Delegation Dig Fails
« Reply #1 on: November 25, 2014, 05:04:55 AM »

Your output shows that you couldn't connect to NS1, not that it wasn't serving information. My output below connects but shows that NS1 doesn't know anything about NS for that domain:

Code: [Select]
~$ dig ns domain.co.za @ns1.he.net

; <<>> DiG 9.9.5-3-Ubuntu <<>> ns domain.co.za @ns1.he.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49223
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 2800
;; QUESTION SECTION:
;domain.co.za.                  IN      NS

;; Query time: 3 msec
;; SERVER: 216.218.130.2#53(216.218.130.2)
;; WHEN: Tue Nov 25 05:02:33 PST 2014
;; MSG SIZE  rcvd: 41

You should check how you entered the domain into dns.he.net.
Logged

keyoke

  • Newbie
  • *
  • Posts: 3
Re: DNS Delegation Dig Fails
« Reply #2 on: November 25, 2014, 07:10:31 AM »

Hi,
Thanks for the response - it seems it doesn't matter what ns query I run locally I always get a timeout. Surely I should get the same response as you?

C:\>dig ns domain.co.za @ns1.he.net

; <<>> DiG 9.10.1 <<>> ns domain.co.za @ns1.he.net
;; global options: +cmd
;; connection timed out; no servers could be reached


if I run the query using online dig tool I get a response

; <<>> DiG 9.7.3 <<>> -t NS @ns1.he.net domain.co.za
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6438
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;domain.co.za.         IN   NS

;; Query time: 169 msec
;; SERVER: 216.218.130.2#53(216.218.130.2)
;; WHEN: Wed Nov 26 01:18:28 2014
;; MSG SIZE  rcvd: 32

why do I get different responses locally and remotely?
« Last Edit: November 25, 2014, 07:23:03 AM by keyoke »
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1717
Re: DNS Delegation Dig Fails
« Reply #3 on: November 25, 2014, 08:38:04 AM »

If you cannot reach ns1, that sounds like an IPv4 connectivity issue on your side. You should also probably post a screenshot of your domain config in dns.he.net since none of us can log in and see what you've done. Only the admins can do that, and you should be emailing them to have them look.
Logged

keyoke

  • Newbie
  • *
  • Posts: 3
Re: DNS Delegation Dig Fails
« Reply #4 on: November 25, 2014, 12:05:00 PM »

thanks have contacted support and they have provided solution. cheers
Logged