Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Broken IPv6 on US government websites?  (Read 2533 times)

ultradian

  • Newbie
  • *
  • Posts: 1
Broken IPv6 on US government websites?
« on: April 29, 2015, 09:36:29 AM »

We're having difficulty accessing certain US government websites via the tunnel. I think this is due to breakage on their end: the server appears to complete the TCP 3-way handshake, then stops communicating. We've noticed this problem specifically on clinicaltrials.gov and uspto.gov. We've temporarily worked around the issue by blacklisting the v6 IPs in our router; I was curious if anyone else had noticed anything like this.

-Andrew
Logged

eduperez

  • Newbie
  • *
  • Posts: 5
Re: Broken IPv6 on US government websites?
« Reply #1 on: June 17, 2015, 07:42:52 AM »

I can browse both sites without issues.
Logged

snarked

  • Hero Member
  • *****
  • Posts: 757
Re: Broken IPv6 on US government websites?
« Reply #2 on: June 19, 2015, 06:09:25 PM »

I can confirm that certain U.S. Gov't websites are indeed broken.  The FCC's web site has parts which are unreachable despite having an IPv6 address.  It also has MTU problems with its FTP server where I have to manually set the MTU to 1450 in order to get it to work, even with IPv4.  The MTU problem could be solved if there weren't some brain-dead router in the middle or on their end that would stop blocking ICMP "packet too big" responses.

I have not tried the two sites mentioned in the originating post of this thread.
Logged

Napsterbater

  • Newbie
  • *
  • Posts: 29
Re: Broken IPv6 on US government websites?
« Reply #3 on: June 21, 2015, 11:14:38 PM »

I can confirm issues with both with an MTU of 1480.
Logged

steve1515

  • Newbie
  • *
  • Posts: 13
Re: Broken IPv6 on US government websites?
« Reply #4 on: September 07, 2015, 07:22:18 PM »

I'm seeing the same problem with www.ssa.gov which resolves to 2001:1930:d07::aaaa. This only happens via an HE tunnel. I tried it from my Verizon Mobile hotspot which supports IPv6 and the site works correctly.

Is anyone else seeing this problem?
Logged

steve1515

  • Newbie
  • *
  • Posts: 13
Re: Broken IPv6 on US government websites?
« Reply #5 on: October 21, 2015, 04:32:44 PM »

I can confirm that my problem is solved when I force my MSS to 1420.
Logged