Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  


Welcome to Hurricane Electric's forums!

Author Topic: GURU: stuck despite all NS having AAAA RR - Solved.  (Read 2850 times)


  • Newbie
  • *
  • Posts: 2
GURU: stuck despite all NS having AAAA RR - Solved.
« on: September 05, 2015, 02:23:31 AM »

problem solved. no other name was allowed, but removing the www completely worked.

The guru level test says:

Congratulations, you are an IPv6 Professional! To complete the Guru Test you will need:
The Name Servers for need to have a AAAA records
Those nameservers need to respond to queries made via IPv6 and return a AAAA record for

Step   Description   Data
1   If you need to edit off any subdomains to make it work, please do so here:   
2   Run the test      
3   Check to see that the nameservers associated with have IPv6 AAAAs   Couldn't get AAAA for NS
4   Check to see that the nameservers associated with are IPv6 accessible   Working

However,  "" is an alias for the canonical name "" which has AAAA records and all three authorative name servers for the domain "" have AAAA records and are reachable via IPv6.

;         IN   ANY

;; ANSWER SECTION:      28800   IN   CNAME

;; AUTHORITY SECTION:      28800   IN   NS      28800   IN   NS      28800   IN   NS

;; ADDITIONAL SECTION:      28800   IN   A      28800   IN   AAAA   2a01:4f8:130:5206::35      28800   IN   A      28800   IN   AAAA   2a01:4f8:110:3261::35      1245   IN   A      1245   IN   AAAA   2001:1440:201:101::6

Of course there is no glue record in the .net zone for the .de NS (different hierarchy), but that should not break this test.
And since is a CNAME, there is no way to add any form of sub level domain.

The test refuses any other name (e.g. the canonical name "") that does not end in "".
Is this test broken by the CNAME or by the lack of foreign glue in .NET zone?

All hosts involved have working IPv6. How can i get this test to work correctly?[/s]
« Last Edit: September 05, 2015, 03:08:22 AM by JPM4HE »


  • Newbie
  • *
  • Posts: 2
Re: GURU: stuck despite all NS having AAAA RR
« Reply #1 on: September 05, 2015, 02:40:47 AM »

Ah, i was not able to change the "www" to anything else, but i was able to remove it.

The test succeeded using only the domain name.