Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Problems setting up tunnel  (Read 2691 times)

bengreenwood

  • Newbie
  • *
  • Posts: 3
    • View Profile
Problems setting up tunnel
« on: January 25, 2016, 01:57:48 AM »

Hi Guys,

Complete novice with IPV6, this is my first attempt at anything so please forgive my stupidity.

I tried to set up the tunnel over the weekend but it doesnt seem to have worked.

My primary goal is to connect MySQL Workbench to a database hosted on google cloud services using IPV6 as they offer free V6 addresses but charge for V4 addresses.

OK so i followed the tunnel setup in the FAQs and ran the sample config commands. Can someone provide any assistance? what information do i need to give you to be helpful?

Cheers
Ben
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2586
    • View Profile
Re: Problems setting up tunnel
« Reply #1 on: January 25, 2016, 05:28:34 AM »

What commands did you run?
Logged

bengreenwood

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Problems setting up tunnel
« Reply #2 on: January 26, 2016, 01:30:10 AM »

Hi,

I used this FAQ...

Quote
[Tunnel Broker]

I've tried to create a tunnel but did not succeed. Is there a basic guideline on how to set up a tunnel?

Visit our tunnelbroker.net site and log in.
Once you log into the site, click "Create Regular Tunnel" and provide your IPv4 endpoint address and choose a preferable tunnel server location. (Note: Your IPv4 endpoint address should be displayed on the tunnel creation page)
After you successfully create a tunnel, visit your tunnel's detail page and choose your OS type to get example configuration commands.
Use the commands to configure your machine. Please remember, you must have 'administrator' privilege to configure your machine.
Once you configure your machine, please browse sites like http://ipv6.google.com or http://kame.net to test your IPv6 connectivity.

*Two important notes:
Your IPv4 endpoint address must be reachable via ICMP ECHO_REQUEST (Internet Control Message Protocol).
If you are using a NAT (Network Address Translation) appliance, please make sure it allows and forwards IP protocol 41.
What is IP Protocol 41?
IP Protocol 41 is one of the Internet Protocol numbers. Within the IPv4 header, the IPv4 Protocol field is set to 41 to indicate an encapsulated IPv6 packet.
**Useful references:
Video Tutorials: http://ipv6.he.net/presentations.php
Tunnel Broker Forums: http://tunnelbroker.net/forums/

and used these commands from the example config (windows 7)

Code: [Select]
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel 94.192.149.68 216.66.80.26
netsh interface ipv6 add address IP6Tunnel 2001:470:1f08:b5b::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f08:b5b::1

when i log into tunnel broker it says i have 1 configured tunnel, but when i try to browse to IPV6 google for example it doesnt work
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1678
    • View Profile
    • Another IPv6 Blog...
Re: Problems setting up tunnel
« Reply #3 on: January 26, 2016, 02:21:36 AM »

Is 94.192.149.68 actually configured on your Windows machine? Probably not. There is a NOTE in bold that tells you that when running the example commands, to replace 94.192.149.68 with your internal NAT IP. Try that.
Logged

bengreenwood

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Problems setting up tunnel
« Reply #4 on: January 26, 2016, 07:35:24 AM »

Hi Sorry im not sure i understand, is the NAT address the internal address of my router?

I'm setup

Laptop --> Router --> Web (nothing inbetween)

Cheers
Ben
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2586
    • View Profile
Re: Problems setting up tunnel
« Reply #5 on: January 26, 2016, 07:36:23 AM »

Where are you hosting the tunnel? If it's on your computer, you need to use the IP address that's on your LAN interface
Logged