Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: IPV6 fallback to IPV4 not working - OSX 10.11  (Read 1048 times)

SteMax97

  • Newbie
  • *
  • Posts: 2
    • View Profile
IPV6 fallback to IPV4 not working - OSX 10.11
« on: May 26, 2016, 08:15:02 AM »

Hello everybody,
I am using a MacBook Pro Retina 15 from 2013. My ISP doesn't provide IPV6 connectivity yet, so I created a IPV6 tunnel using Hurricane Electric's service. I set up a Raspberry Pi to give IPV6 addresses on my subnet and everything works as expected. I have IPV6 connectivity on my MacBook and I can browse IPV6 sites. I did a test on http://ipv6-test.com . The results were positive but it was said that my browser (latest version of Google Chrome, but the problem is on Safari and Firefox too) doesn't have fallback compatibility. If I try the test again on Windows, Android, ecc. the warning message disappears.
The problem is that I can't browse all websites using my MacBook. For example, the Apple website wasn't appearing: I ran wireshark and Chrome was trying to load everything using IPV6, without success. Also trying to access https://eolo.it/ (my ISP website) generates errors: it doesn't always work on my MacBook, whereas opening it on Windows and IPV6 doesn't have any problems at all. I think that my MacBook (or in general OSX El Capitan) isn't able to fallback to iPV4 when the website has a IPV6 but it isn't working. I read about "Happy eyeballs" and I'd like to know how to solve my problem.
I know I could switch IPV6 off, but I'd prefer to have it and at the same I'd like to be able to use iPV6 when my ISP provides me an IPV6 address.
Thanks you in advance.

OS X El Capitan (10.11.5)
Logged

aandaluz

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: IPV6 fallback to IPV4 not working - OSX 10.11
« Reply #1 on: June 02, 2016, 06:18:06 AM »

My setup is similar to yours. According to Apple, happy eyeballs on elCapitan will fallback to ipv4 if the difference in responses for both protocols is greater than 25 ms. Getting around Apple's "Hampering Eyeballs

Perhaps at some point ICMP responses with " "packet too large" may not be reaching your router. Try setting your MTU to the minimum supported value (1280 instead of 1480). You can do this from your tunnelbroker account, or via your router ipv6 config. See
[Connection Problems] [Hint: MTU] Reducing MTU for tunnel

 
Logged