• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

HE tunnel not working with new ISP

Started by mattwilson9090, August 28, 2016, 04:56:13 PM

Previous topic - Next topic


Trying this post again, the first one failed due to the attachment, so now I get to write it all over again.

Until recently I'd been happily connected to my LA tunnel which I created in 2011. For the last 2 years I've beening an ASUS RT-N66U using Toastman firmware (currently 1.28.0510.1, but there have been several incremental upgrades in the last few months). I realize the Frement and Seattle tunnels might be closer in "internet distance" but I don't think they existed when I created it.

Then I changed to my municipal ISP, using their fiber service that gives me 300 Mbps up and down. I initially had all sorts of problems with it, massive dropped packets, failure to connect to websites, Office365 not connecting in Outlook. I narrowed it down to the tunnel, and when I disable it everything works great. Except of course I no longer have IPv6.

Now I want to get it running again.

When I connect to the tunnel I'm able to ping the IPv4 and IPv6 addresses associated with the tunnel, plus I can ping OpenDNS "sandbox" IPv6 DNS servers. But like I said, things are broken. When I run a test at http://test-ipv6.com/ it doesn't even recognize my IPv6 addresses and says I have a broken or misconfigured IPv6 setup. I'd attach a screenshot, but posting fails every time I try.

To see if it was an issue between my router and ISP I tried configuring my Win7 computer as the tunnel endpoint, but with no luck.

Here are the commands from the HE site I tried, but they didn't seem to create the tunnel

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel
netsh interface ipv6 add address IP6Tunnel 2001:470:c:10bb::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:c:10bb::1

When I read the notes I realized the second command was probably incorrect, so after deleting the tunnel, substituted my machines address for the one the router configuration is trying to use.

netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel

Unfortunately that gave me a response of "Element not found"

Note, the ASUS router is behind the ISP's "modem"/router, so isn't actually the WAN address on the router, but with the other ISP I was also behind another router, so I don't think that matters. Also, I disabled all all IPv6 tunnel interfaces on this PC when I set it up, using the "fixit" at https://support.microsoft.com/en-us/kb/929852

At this point I'm not sure how to proceed. I'm half convinced it's an issue with my ISP, but I'd prefer to have some more data before opening a ticket with them. For testing purposes I have no problem getting the tunnel terminated on the PC, but obviously the main goal is to get it working again on the router.

Thoughts, suggestions?
Matt Wilson


When you deleted the tunnel, did you reset the entire ipv6 subsystem or just delete the tunnel?


Yes, I reset with "netsh int ip reset" and then rebooted. It did not restored any of the IPv6 transition technologies, but I assume that's controlled in another way.
Matt Wilson


Just a follow up. I pulled my head out of my butt and reran the options at https://support.microsoft.com/en-us/kb/929852 This time I enabled IPv6 on tunnels on the computer and was able to successfully execute the netsh commands needed to setup the HE tunnel terminating on my PC.

It did allow me to create the tunnel, and I was able to ping IPv6 addresses. That's the good news. The bad news is that I'm still having the same problems as when I was terminating the tunnel on my router. That's also the good news since it tends to point to an issue with my new ISP, perhaps an interaction with the router, or maybe something with the way they are managing or routing the traffic. It could also indicate a problem with the tunnel, but I think that if this kind of issue was going on with it we'd be hearing something about it here in the forum.
Matt Wilson


has there been a change to MTU after changing ISPs?

ex. MTU of 1480 for a 6in4 tunnel using a cable provider vs MTU of 1472 for fiber if using pppoe without baby jumbo frames?


With the previous ISP MTU was left at default, both for the WAN connection and the tunnel, though I'm not sure what the values actually were. For the WAN MTU is still at default, 1500. For the tunnel I've tried different settings. Initially I was getting a lot of dropped packets so I lowered it to 1280, which helped with the dropped packets, but nothing else. This fiber connection is not PPOE, and unless I've missed a setting somewhere jumbo frames isn't enabled anywhere.

I just double checked MTU on the ISP's modem/router, and it's set at 1500, though it doesn't look like there's a mechanism to change it.
Matt Wilson