Hurricane Electric's IPv6 Tunnel Broker Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Can't update  (Read 389 times)

uniserv

  • Newbie
  • *
  • Posts: 3
    • View Profile
Can't update
« on: November 16, 2016, 12:59:31 PM »

Hello.
I try several times tried to update my ipv4 address by way of script, without success. :'(
I have to open a browser every time to do it manually.

Here's the script:
Code: [Select]
Curl 'https://ipv4.tunnelbroker.net/nic/update?username=uniserv&password=xxxxxx&hostname=xxxxxx'
In response I get 'badauth' or 'notfqdn'

Could you help me find out what's wrong, please.
Logged

snarked

  • Hero Member
  • *****
  • Posts: 675
    • View Profile
Re: Can't update
« Reply #1 on: November 17, 2016, 10:49:42 AM »

How are you sending the PW - plain-text or hashed (i.e. encoded)?  Have you tried the other format....?
Logged

uniserv

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Can't update
« Reply #2 on: November 23, 2016, 04:46:24 PM »

Hello,
First, sorry for this prolonged absence.
I tried of course the two methods proposed. Plain text and text with the update key given on page: https://ipv4.tunnelbroker.net/tunnel_detail.php?tid=XXXXXX
But an idea comes to me. The encoded variant is the one given by the example page?
Otherwise I must encode the PW with what format. Type mkpasswd -m sha-512 OnePassWord?

thanks.
Logged

uniserv

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Can't update
« Reply #3 on: November 23, 2016, 05:22:12 PM »


I have tried several formulas, the last :
Curl -u "uniserv: $ UPKEYENCODED" 'https://ipv4.tunnelbroker.net/nic/update?hostname=371093&myip=$IP'
answer is "good 127.0.0.1".
Why 127.0.0.1?
I checked after on the page https://ipv4.tunnelbroker.net/tunnel_detail.php?tid=ID, to find that the endpoint has not changed
Logged