Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  


Welcome to Hurricane Electric's forums!

Author Topic: Debian router behind NAT, client in LAN cant ping server endpoint.  (Read 900 times)


  • Newbie
  • *
  • Posts: 1
    • View Profile

Iam currently stuck getting debian server to work with my client (Ubuntu). The tunnel is working succefully from the server but i cant get it to work for my client. 

From my client i can ping to the server but not to the ipv6 endpoint.
I also enabled port forwarding so it is allowed.

This is my client ips: (For some reason i get two global IP:s)

          inet addr:  Bcast:  Mask:
          inet6 addr: yyyy:yyyy:28:26d:798f:d356:1d98:3906/64 Scope:Global
          inet6 addr: fe80::7a0f:d0b7:5638:4909/64 Scope:Link
          inet6 addr: yyyy:yyyy:28:26d:4c54:1bc9:133c:2da1/64 Scope:Global


interface eth0
   AdvSendAdvert on;

   prefix yyyy:yyyy:28:26d::/64
AdvOnLink on;
AdvAutonomous on;

RDNSS 2a01:e00::0


source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

iface eth0 inet6 static
 address yyyy:yyyy:28:26d:f66d:04ff:fe06:f27b
 netmask 64
 gateway yyyy:yyyy:27:26d::2

auto he-ipv6
iface he-ipv6 inet6 v4tunnel
        address yyyy:yyyy:27:26d::2
        netmask 64
        ttl 255
        gateway yyyy:yyyy:27:26d::1

I tried several combinations and probably been working with this for over 20 hours now  :o
« Last Edit: January 17, 2017, 07:28:05 AM by tfk16onr »