Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: I screwed up my Mac settings  (Read 241 times)

mizhou

  • Newbie
  • *
  • Posts: 1
    • View Profile
I screwed up my Mac settings
« on: May 21, 2017, 08:17:33 PM »

At first I configured my Mac with the settings as follows:
ifconfig gif0 create
ifconfig gif0 tunnel xx.yy.zz.qq 216.66.80.90
ifconfig gif0 inet6 2001:aaa:bbb:ccc::2 2001:aaa:bbb:ccc::1 prefixlen 128
route -n add -inet6 default 2001:aaa:bbb:ccc::1

where xx.yy.zz.qq is the IP I get from my ISP, and aaa:bbb:ccc is substitutes for the real parts of the IPv6 address in this example (not the IP adress I used to configure the Mac). Of course this was wrong, since I'm behind a router, but I was tired when I did this. I know it's a bad excuse, but that's the way it is.

I then set up my router (Apples Time Capsule) and the tunnel sees to be working. At least from my iPhone. The phone gets a public IPv6 address and it works, but on the Mac I only get a link-local address now. I have tried reversing the setup I did on the Mac, like "ifconfig gif0 destroy", and then setup from System Preferences and there I set it to Automatic, so that I use the prefix I get from the router, and then assign the lower 64 bits automatically on the Mac. The iPhone gets the prefix from the router, and I get a fullt working address there, but on the Mac this doesn't seem to work now.

I did something wrong when trying to revert the:
ifconfig gif0 create
ifconfig gif0 tunnel xx.yy.zz.qq 216.66.80.90
ifconfig gif0 inet6 2001:aaa:bbb:ccc::2 2001:aaa:bbb:ccc::1 prefixlen 128
route -n add -inet6 default 2001:aaa:bbb:ccc::1

So something is screwed up. I've tried to google for a good answer, but haven't found one.
I've also tried route -n delete -inet6 default 2001:aaa:bbb:ccc::1 and after that ifconfig gif0 destroy

And yes, I used sudo on all those command lines, since the higher privileges are needed to configure network interface settings.

This is what it looks like on en0:(which is the interface I want to setup for IPv6) on the Mac now:
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
   options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
   ether a8:20:66:32:02:c4
   inet 10.0.64.2 netmask 0xffffff00 broadcast 10.0.64.255
   inet6 fe80::c7b:f438:d9ba:7c58%en0 prefixlen 64 secured scopeid 0x4
   nd6 options=201<PERFORMNUD,DAD>
   media: autoselect (1000baseT <full-duplex,flow-control>)
   status: active

en0 is my ethernet port. I have also tried on WiFi (en1:) but also in that one I only get a link-local IPv6
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
   ether 20:c9:d0:97:b4:33
   inet6 fe80::4fd:da9d:98bd:ff81%en1 prefixlen 64 secured scopeid 0x5
   inet 10.0.64.3 netmask 0xffffff00 broadcast 10.0.64.255
   nd6 options=201<PERFORMNUD,DAD>
   media: autoselect
   status: active

In System preferences->Network I have now set IPv6 to automatic, so I thought I should get IPv6 address from the router, like the iPhone gets one. The iPhone gets both a link-local and two global addresses within my /64 block. The Mac gets only the link-local, so I don't think there's any problem with the configuration on the Time Capsule. I think my initial configuration in the Terminal on the Mac screwed up something on the Mac.
Logged