Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Problem resolving a hostname of IPv6-only (DS-Lite) server  (Read 7808 times)

maxmarauder

  • Newbie
  • *
  • Posts: 2
Problem resolving a hostname of IPv6-only (DS-Lite) server
« on: October 07, 2018, 11:04:52 AM »

Hi Everyone!

I've setup a Minecraft server on a Raspberry Pi (running Raspbian) at my home.
My ISP provides me with DS-Lite connection, so there's only IPv6 visible from the internet.
I've registered a domain name and set it up at dns.he.net, adding only 1 AAAA record (since I don't have any IPv4 for an A record).
Currently the info about my domain is already propagated across the world, and I can see that it's resolved with the correct IPv6 address of my Raspberry Pi
(see https://dnschecker.org/#AAAA/marauder.ga)
However, neither by Minecraft client, nor via SSH can I connect to my server using the domain name. It says: host cannot be resolved.
Even though in Putty which I use for SSH connection I explicitly set an option "prefer IPv6 protocol".
Same with Nmap port scanner: I use -6 flag (which means use IPv6), but it's also unable to resolve.
At the same time I connect perfectly to a plain IPv6 address with all the mentioned tools.

Any ideas are appreciated.
Logged

kriteknetworks

  • Sr. Member
  • ****
  • Posts: 259
    • aRDy Music
Re: Problem resolving a hostname of IPv6-only (DS-Lite) server
« Reply #1 on: October 09, 2018, 06:18:29 AM »

You didnt mention what dns resolvers are being used. I can resolve marauder.ga fine. From the client machine try a dig +trace aaaa marauder.ga
Logged

maxmarauder

  • Newbie
  • *
  • Posts: 2
Re: Problem resolving a hostname of IPv6-only (DS-Lite) server
« Reply #2 on: October 09, 2018, 08:45:10 AM »

kriteknetworks, sorry, I'm far from expert in the DNS topic, and not quite understand what you mean by: "what dns resolvers are being used".

I just tried to connect my server with various apps like Minecraft client, Putty, also tried to scan ports that I know are open, like 22 (SSH) and 25565 (Minecraft), and nothing of that was able to resolve marauder.ga.

Tried what you suggested:
Code: [Select]
$ dig +trace aaaa marauder.ga

; <<>> DiG 9.10.6 <<>> +trace aaaa marauder.ga
;; global options: +cmd
;; connection timed out; no servers could be reached
Logged

snarked

  • Hero Member
  • *****
  • Posts: 730
Re: Problem resolving a hostname of IPv6-only (DS-Lite) server
« Reply #3 on: October 09, 2018, 10:21:20 PM »

There's your problem.  You're using zero.
Logged