Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: news.ipv6.eweka.nl - Trace Route Failed  (Read 10618 times)

ngjvjRbYM

  • Newbie
  • *
  • Posts: 23
news.ipv6.eweka.nl - Trace Route Failed
« on: April 18, 2009, 05:31:27 AM »

I have tested some "routers" with the "Looking Glass" of your site and
found one who can't reach 2001:4de0:1::1:1 / news.ipv6.eweka.nl.

core1.ams1.he.net = error



Something other i noticed is the route taken from "core1.lon1.he.net" to news.ipv6.eweka.nl.

Is using "5-3.r2.lo.v6.hwng.net" (2001:4de0:1000:24::1)  and "1-3.r3.lo.v6.hwng.net" (2001:4de0:1000:25::1)
both from the same network. Is it not better to skip one of the two.

The "core1.fra1.he.net" has something similar.
Is using "3-1.r1.am.v6.hwng.net" (2001:4de0:1000:3::1) and "1-1.r2.am.v6.hwng.net" (2001:4de0:1000:1::2)
both from the same network. Is it not better to skip one of the two.

It looks to me that a shorter traceroute is better for the latency or not?
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1722
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #1 on: April 18, 2009, 12:39:31 PM »

Seeing as it is peering at different locations, we'll use what the peer provides for path. That is the path INSIDE their network, not ours.
We'll poke them about the AMS-IX session.

EDIT - and email fired off letting them know
« Last Edit: April 18, 2009, 12:51:10 PM by broquea »
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1722
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #2 on: April 18, 2009, 02:43:50 PM »

Incidentally, can you successfully trace with your own machine? My FreeBSD server mounted under our router, goes through without issue:

Code: [Select]
1  gige-g2-20.core1.ams1.he.net  0.375 ms  0.349 ms  0.279 ms
 2  ams-ix.hwng.net  1.129 ms  0.932 ms  0.721 ms
 3  2001:4de0:a::a  0.885 ms  0.926 ms  1.539 ms
 4  2001:4de0:1::1:1  15.404 ms  0.893 ms  2.350 ms

We're in communication with them now trying to sort it out from the router's perspective.
« Last Edit: April 18, 2009, 02:47:46 PM by broquea »
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1722
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #3 on: April 18, 2009, 03:34:26 PM »

From the peer:

Code: [Select]
Found the 'issue'.  The traceroute is sourcing from your amsix ipv6 addres.

amsix is announcing that exchange prefix block via ASN1200 but tagging
it with no export.  The ip your trying to trace to is off another ASN of
ours so the route isn't getting advertised into that network.

show ipv6 bgp route detail 2001:7f8:1::/48
Number of BGP Routes matching display condition : 3
Status A:AGGREGATE B:BEST b:NOT-INSTALLED-BEST C:CONFED_EBGP D:DAMPED
       E:EBGP H:HISTORY I:IBGP L:LOCAL M:MULTIPATH m:NOT-INSTALLED-MULTIPATH
       S:SUPPRESSED F:FILTERED s:STALE
1       Prefix: 2001:7f8:1::/48,  Status: BE,  Age: 25d12h44m12s
         NEXT_HOP: 2001:7f8:1::a500:1200:1, Metric: 1,  Learned from
Peer: 2001:7f8:1::a500:1200:1 (1200)
          LOCAL_PREF: 200,  MED: none,  ORIGIN: igp,  Weight: 0
           AS_PATH: 1200
            COMMUNITIES: no-export 12989:15 12989:2201
            Adj_RIB_out count: 20,  Admin distance 20
2       Prefix: 2001:7f8:1::/48,  Status: E,  Age: 45d6h22m39s
         NEXT_HOP: 2001:7f8:1::a500:1200:2, Metric: 1,  Learned from
Peer: 2001:7f8:1::a500:1200:2 (1200)
          LOCAL_PREF: 200,  MED: none,  ORIGIN: igp,  Weight: 0
           AS_PATH: 1200
            COMMUNITIES: no-export 12989:15 12989:2201

There is no route back to the source as intended by ams-ix

________
Highwinds Network Group
Logged

ngjvjRbYM

  • Newbie
  • *
  • Posts: 23
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #4 on: April 18, 2009, 04:56:00 PM »

I am able to ping6 and tracert6 news.ipv6.eweka.nl. I am using "core1.lon1.he.net".
On this moment the server is going from 'connecting' to 'offline', no data is send.
This problem was not a hour ago. Maybe this is a temporary problem because they are working on a solution.
I am going to reset my ipv6 settings to rule out that this is a local problem.

edit: The problem still exists after uninstalling ipv6, reboot, re-install ipv6 and load my settings.
edit2: On this moment the connection is stable.
« Last Edit: April 19, 2009, 05:54:59 AM by ngjvjRbYM »
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1722
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #5 on: April 18, 2009, 05:08:19 PM »

Ok I meant don't use our LG/routers, can you do this from your personal machine? Clearly it will NEVER work tracing off the AMS router since AMS-IX does NO EXPORT on their exchange /48 whereas LINX and DE-CIX don't do that it seems.

I am able to ping6 and tracert6 news.ipv6.eweka.nl. I am using "core1.lon1.he.net".
On this moment the server is going from 'connecting' to 'offline', no data is send.
This problem was not a hour ago. Maybe this is a temporary problem because they are working on a solution.
I am going to reset my ipv6 settings to rule out that this is a local problem.

Logged

ngjvjRbYM

  • Newbie
  • *
  • Posts: 23
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #6 on: April 18, 2009, 05:10:04 PM »

I have done the ping6 and tracert6 local. This works for me.This is with a tunnel using lon1.

tracert6 news.ipv6.eweka.nl
  1       22 ms    21 ms    21 ms  2001:470:1f08:657::1
  2       22 ms    21 ms    20 ms  gige-g4-6.core1.lon1.he.net [2001:470:0:67::1]
  3       28 ms    35 ms    28 ms  2001:7f8:4::32bd:1
  4       28 ms    28 ms    28 ms  5-3.r2.lo.v6.hwng.net [2001:4de0:1000:24::1]
  5       28 ms    42 ms    28 ms  1-3.r3.lo.v6.hwng.net [2001:4de0:1000:25::1]
  6       27 ms    28 ms    28 ms  5-2.r2.am.v6.hwng.net [2001:4de0:1000:26::2]
  7       41 ms    38 ms    37 ms  2001:4de0:a::a
  8       28 ms    27 ms    28 ms  2001:4de0:1::1:1

ping6 news.ipv6.eweka.nl
Min= 27ms, max= 40ms, average= 30ms
« Last Edit: April 19, 2009, 04:58:16 PM by ngjvjRbYM »
Logged

ngjvjRbYM

  • Newbie
  • *
  • Posts: 23
Re: news.ipv6.eweka.nl - Trace Route Failed
« Reply #7 on: April 19, 2009, 12:45:27 PM »

I have done the ping6 and tracert6 local. This works for me. This is with a tunnel using ams1.

tracert6 news.ipv6.eweka.nl
  1       47 ms    27 ms    27 ms  2001:470:1f14:387::1
  2        *         36 ms    24 ms  gige-g2-20.core1.ams1.he.net [2001:470:0:7d::1]
  3       27 ms    31 ms    49 ms  ams-ix.hwng.net [2001:7f8:1::a501:2989:1]
  4        *         25 ms    25 ms  2001:4de0:a::a
  5       46 ms     *         27 ms  2001:4de0:1::1:1

ping6 news.ipv6.eweka.nl
Min= 26ms, max= 47ms, average= 32ms
« Last Edit: April 19, 2009, 04:55:52 PM by ngjvjRbYM »
Logged