• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Issues with Ping and Traceroute on Windows 10

Started by jianglai, April 21, 2020, 10:18:03 AM

Previous topic - Next topic



First of all, thank you for providing the tunnel broker service for free! I was able to set it up on my router and all my LAN devices get assigned routed /64 IPv6 addresses and can access IPv6 internet. However I noticed a strange issue only on my Windows 10 machines. I was not able to ping and traceroute (tracert) times out after three hops at ve422.core1.nyc4.he.net:

ping -6 ipv6.google.com

Pinging ipv6.l.google.com [2607:f8b0:4006:805::200e] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

tracert ipv6.google.com

Tracing route to ipv6.l.google.com [2607:f8b0:4006:805::200e]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms [Client endpoint address of my tunnel]
  2     6 ms     7 ms     5 ms  tunnelXXXXXX.tunnel.tserv4.nyc4.ipv6.he.net [2001:470:XXXX:XXXX::1]
  3     4 ms     3 ms     3 ms  ve422.core1.nyc4.he.net [2001:470:0:5d::1]
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7     *        *        *     Request timed out.
  8     *        *        *     Request timed out.
  9     *        *        *     Request timed out.
10     *        *        *     Request timed out.
11     *        *        *     Request timed out.

For comparison the same requests worked out just fine on both Linux and Mac hosts in the LAN:

$ ping ipv6.google.com
PING ipv6.google.com(lga25s55-in-x0e.1e100.net (2607:f8b0:4006:805::200e)) 56 data bytes
64 bytes from lga25s55-in-x0e.1e100.net (2607:f8b0:4006:805::200e): icmp_seq=1 ttl=56 time=5.20 ms
64 bytes from lga25s55-in-x0e.1e100.net (2607:f8b0:4006:805::200e): icmp_seq=2 ttl=56 time=4.95 ms
64 bytes from lga25s55-in-x0e.1e100.net (2607:f8b0:4006:805::200e): icmp_seq=3 ttl=56 time=4.30 ms

$ traceroute ipv6.google.com
traceroute to ipv6.google.com (2607:f8b0:4006:805::200e), 30 hops max, 80 byte packets
1  [Client endpoint address of my tunnel]  0.460 ms  0.567 ms  0.721 ms
tunnelXXXXXX.tunnel.tserv4.nyc4.ipv6.he.net (2001:470:XXXX:XXXX::1)  9.575 ms  13.332 ms  17.507 ms
ve422.core1.nyc4.he.net (2001:470:0:5d::1)  17.723 ms  17.703 ms  17.733 ms
core1-0-0-8.lga.net.google.com (2001:504:f::27)  18.307 ms  18.268 ms  18.247 ms
5  2001:4860:0:1125::1 (2001:4860:0:1125::1)  19.356 ms 2001:4860:0:1127::1 (2001:4860:0:1127::1)  18.507 ms  18.559 ms
6  2001:4860:0:1::1cef (2001:4860:0:1::1cef)  18.490 ms  14.866 ms  14.818 ms
lga25s55-in-x0e.1e100.net (2607:f8b0:4006:805::200e)  14.845 ms  5.305 ms  5.247 ms

The Windows 10 host can browse the IPv6 internet without any issues (though ipv6-test.com says that ICMPv6 timed out on it even though I have configured the firewall properly both on my router and on the Windows host. When I had native IPv6 through my previous ISP with the same firewall rules the Windows host can receive ICMPv6 from ipv6-test. All my other hosts pass ipv6-test.com with 20/20 as well).

Any idea what could be the problem here? I tried to spin up a Linux VM on the windows host with bridged connections and ping and traceroute worked fine on it, so I know that there shouldn't be any issue at the link level at least.