Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: New to IPv6, issues with internet websites.  (Read 759 times)

gregu6

  • Newbie
  • *
  • Posts: 3
New to IPv6, issues with internet websites.
« on: March 04, 2021, 03:19:12 PM »

Hello all,
 i have recently configured ipv6 in 4 tunnel from HE. I am using edgerouter, that is sharing internet connection with local network clients.
Since i just started with the ipv6, i am not sure if its me that configured something incorrectly, or maybe its just the way it is. Would this be normal that i can't open websites for example:
https://tunnelbroker.net/
When my tunnel is estanblished?
I can ping v6 google, HE dns, the unnel endpoint client/server. But there are really a lot of websites i can't even open. I am really baffled.
I also do not understand what is happening if i am using windows client for example. and i have my local lan ipv4, + i also have now ipv6 from HE tunnel.
IF my browser opens google.com, is it opening the v6 or v4 version of it ?
Once connected with tunnel, i dont have problem for example opening google.com, but majority of websites from results.
I am also wondering if this is normal that the website from ipv6 tunnel broker is not opening. It's probably something on my end i guess.
Could anyone share any advice, or also recommend some books/trainings would be better to start reading in order to get some proper understanding  ?

Thank you in advance,
Greg
Logged

gregu6

  • Newbie
  • *
  • Posts: 3
Re: New to IPv6, issues with internet websites.
« Reply #1 on: March 05, 2021, 11:45:58 AM »

I see this strange behavior depending on which mirror of ipv6-test i would go
via http://test-ipv6.zw.liquidtelecom.net/index.html.en_US
Test with IPv4 DNS record       
ok (0.428s) using ipv4
Test with IPv6 DNS record       
ok (0.498s) using ipv6
Test with Dual Stack DNS record       
ok (0.500s) using ipv6
Test for Dual Stack DNS and large packet       
ok (2.045s) using ipv6
Test IPv4 without DNS       
ok (0.422s) using ipv4
Test IPv6 without DNS       
ok (1.010s) using ipv6
Test IPv6 large packet       
ok (2.286s) using ipv6
Test if your ISP's DNS server uses IPv6       
ok (2.060s) using ipv6
Find IPv4 Service Provider       
ok (0.188s) using ipv4 ASN 1136
Find IPv6 Service Provider       
ok (0.215s) using ipv6 ASN 6939

and via http://test-ipv6.se/index.html.en_US
Test with IPv4 DNS record       
ok (0.118s) using ipv4
Test with IPv6 DNS record       
ok (0.120s) using ipv6
Test with Dual Stack DNS record       
ok (0.121s) using ipv6
Test for Dual Stack DNS and large packet       
timeout (15.265s)
Test IPv4 without DNS       
ok (0.101s) using ipv4
Test IPv6 without DNS       
ok (2.253s) using ipv6
Test IPv6 large packet       
timeout (15.309s)
Test if your ISP's DNS server uses IPv6       
ok (0.139s) using ipv6
Find IPv4 Service Provider       
ok (0.336s) using ipv4 ASN 1136
Find IPv6 Service Provider       
ok (0.401s) using ipv6 ASN 6939


Logged

tomkep

  • Newbie
  • *
  • Posts: 13
Re: New to IPv6, issues with internet websites.
« Reply #2 on: March 08, 2021, 10:28:11 AM »

Have you properly set MTU of your tunnel interface and MTU in tunnelbroker configuration? It usually is 20 bytes smaller than the MTU of your outgoing interface. Or you can set it to minimum allowed value which is 1280 bytes to play it safe.
Logged

gregu6

  • Newbie
  • *
  • Posts: 3
Re: New to IPv6, issues with internet websites.
« Reply #3 on: March 13, 2021, 12:42:21 AM »

thank you for reply. Indeed that was the case with mtu. After lowering it a bit, my clients were able to use ipv6.
Still, i have been not able to configure it properly at home, my router could do iperf3 with 300Mbit/s , while my client PC could do 100 Kbit/s.
I was unable to set properly mtu, not sure how to do it. It also looks like i don't know if i change it , the change is applied immediately or if i have to wait few minutes.
Logged