Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Netgear WPN824v2 do not pass protocol 41?  (Read 11603 times)

Mendemizo

  • Newbie
  • *
  • Posts: 1
Netgear WPN824v2 do not pass protocol 41?
« on: May 23, 2009, 01:40:51 PM »

Hi

I got a problem with IPv6-tunneling with my Netgear WPN824v2 router. Im trying to use my tunnel with a laptop running Ubuntu 9.04. I got it working fine with only my modem(my modem dosent have any dhcp or so).
Router WebGUI:

I entred WAN Setup

Connecect Automatically, as Required=ON
Disable SPI Firewall=ON
Default DMZ Server=ON, 192.168.1.3(my laptop)
Respond to Ping on Internet Port=ON
MTU Size (in bytes)=1500 bytes
NAT Filtering=Open



But, it still not work. Does anyone have any idea what I can do? Or does the router make this impossible?

Mendemizo


EDIT: I just discoverd something. When I paste in this in the terminal on my laptop:

ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::209.51.161.14
ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:1f06:e6::2/64
route -A inet6 add ::/0 dev sit1


I can't enter tunnelbroker.net anymore.

EDIT2:

Information from ifconfig:


eth1      Link encap:Ethernet  HWaddr 00:12:f0:89:7e:43 
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::212:f0ff:fe89:7e43/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3249 errors:6 dropped:6 overruns:0 frame:0
          TX packets:714 errors:0 dropped:6 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60990095 (60.9 MB)  TX bytes:569668 (569.6 KB)
          Interrupt:21 Base address:0xa000 Memory:d0400000-d0400fff

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:608 (608.0 B)  TX bytes:608 (608.0 B)

sit0      Link encap:IPv6-in-IPv4 
          inet6 addr: ::127.0.0.1/96 Scope:Unknown
          inet6 addr: ::192.168.1.3/96 Scope:Compat
          UP RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sit1      Link encap:IPv6-in-IPv4 
          inet6 addr: 2001:470:1f06:e6::2/64 Scope:Global
          inet6 addr: fe80::c0a8:103/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:568 (568.0 B)
« Last Edit: May 23, 2009, 02:17:44 PM by Mendemizo »
Logged

snarked

  • Hero Member
  • *****
  • Posts: 765
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #1 on: May 24, 2009, 12:58:46 PM »

Since you're using an RFC 1918 private network with NAT, first make certain that your IPv4 tunnel endpoint specifies a routable IPv4 address (the address of your NAT device).  If you put in 192.168.1.3 instead (a HE's server), then of course your tunnel won't work.
Logged

Whats85

  • Newbie
  • *
  • Posts: 3
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #2 on: January 11, 2011, 03:08:08 AM »

I have the exact same question. Does the Netgear WPN824v2 pass protocol 41? Without the Netgear, directly onto the modem, i got ipv6 working. So everyhing is configured correct.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2714
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #3 on: January 11, 2011, 05:48:45 AM »

Then I would say it's not passing protocol 41.

However, like snarked mentioned, you need to use your NAT'd address to create the tunnel
Logged

Whats85

  • Newbie
  • *
  • Posts: 3
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #4 on: January 11, 2011, 06:05:13 AM »

The tunnel is working fine without the netgear. On the hurricane site the ipv4 client adress is: 83.84.22X.XX. The tunnel on my pc is:

netsh interface ipv6 add v6v4tunnel IP6Tunnel 192.168.1.4 216.66.84.46
netsh interface ipv6 add address IP6Tunnel 2001:470:1f14:a8c::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f14:a8c::1

So is there any chance of getting this working with the Netgear (opening a port, disabling firewall?)
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2714
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #5 on: January 11, 2011, 06:17:04 AM »

Disabling the firewall would let protocol 41 through.

Some routers also have a DMZ..you could try placing your host in there and seeing if that works
Logged

Whats85

  • Newbie
  • *
  • Posts: 3
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #6 on: January 11, 2011, 08:30:13 AM »

Tried to disable SPI firewall and DMZ host but no luck..
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2714
Re: Netgear WPN824v2 do not pass protocol 41?
« Reply #7 on: January 14, 2011, 05:58:03 AM »

Is there any new firmware available?
Logged