• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.


Welcome to Hurricane Electric's Tunnelbroker.net forums!

Main Menu

starnge tunnel

Started by sttun, March 07, 2008, 12:10:27 PM

Previous topic - Next topic


I folowed the instructions on how to set up a tunnel but i cannot ping the romote end of the tunnel (or any other ipv6 address), 100% pacet loss.
So i tried a pacet capture and surprise the trafic flowed perfectly both from me to he and back, so why cant ping6 see the replies?
traceroute6 behaves the same but it reports network unreachable, can this be 2 imdications of the same problem?

I´m using  Linux dhcppc0 2.6.18-53.1.6.el5xen #1 SMP Wed Jan 23 12:33:37 EST 2008 i686 i686 i386 GNU/Linux   (Centos 5)


Are you running any sort of software/hardware firewall or filtering?

I can ping your ipv4 endpoint, but not your side of the ipv6 tunnel.

Everything is configured correctly on the tunnel-server.

Please paste the exact commands you used to bring up your tunnel on your side.



ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::
ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:1f08:17c::2/64
route -A inet6 add ::/0 dev sit1

I´m not ronning any firewall on the machine where the tunnel terminates, this is the machine I tried the ping6/traceroute6 from, It´s behind a nat

update: strange- starnger   I thought I might have missed something, so I ran
ifconfig sit1 down
ifconfig sit0 down
and reran the commands on the top
now bing6 reports
From 2001:470:1f08:17c::2 icmp_seq=0 Destination unreachable: Address unreachable

i allso tried
modprobe ipv6
ip tunnel add he-ipv6 mode sit remote local ttl 255
ip link set he-ipv6 up
ip addr add 2001:470:1f08:17c::2/64 dev he-ipv6
ip route add ::/0 dev he-ipv6
ip -f inet6 addr

with the same result

now the pacet capture shows no trafic at all to/from yore servers


Ok, so your NAT appliance:

- does it pass Protocol41?
- Does it have any configuration options for IPv6?
- When you ran your packet capture, was it while running IPv4 or IPv6 traffic (that part wasn't clear)?


that is a good question i cannot find relevant docs on the router, it´s a zyxel prestige 660RU-T3/E7  and I am unable to get in to the management due to loss of password, and my isp´s helpdesk has been unavalable all day.

As soon as I get that sorted i kan get you mor info.
Thanks for the help so far


Looking at http://www.zyxel.com/web/product_family_detail.php?PC1indexflag=20040812093058&CategoryGroupNo=F9619EE6-1FB3-48FB-B68E-7773E95FF97F

Don't see any mention of IPv6 support. Not much information on their firmware pages either, and the datasheet is just typical marketing.


ok i solved the problem by putting the host running the tunnel in dmz, everything works fine now. Now on the a strange problem: I have set up the same host as a linux ipv6 router with radvd and my /64 allocation on eth0, a client running OSX 10.4.11 receives the advertisemnts fine aand sets up ip routing via the correct gateway and ipv6 connectivety works both ways whike another client using winxp sp2 recives the correct prefix and seems to get the right default gateway but when i try tracert6 to an exsternel ipv6 host all hops times out.
I have disabled ip privacy and the tunnling interfaces but it still reduses to get packets out of my lan.  What is wrong with windows? 


well it looks looks øole yhe problem is with radvd and not windows. radvd onlu senfs out an avertisement containing the default gateway in startup, so witchever client tat is on at tgat moment gets setup correctly but other ckients dont, so I just need to sort out radvd