Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: SuSE: Help setting up 6-routing !  (Read 4032 times)

Ninho

  • Full Member
  • ***
  • Posts: 138
SuSE: Help setting up 6-routing !
« on: September 14, 2009, 02:30:49 AM »

I've setup the tunnel on my SuSE 9.1 box, using the ifconfig/route method per the "pinned" topic in this section.

Now I want to set up this box as the 6-router for the LAN (using the /64 assigned to me by HE). I searched this section but couldn't find quick instructions.

At the moment I just want to do it "by hand" at the command line (no scripting) in order to learn and understand.

Will someone please help ?
Logged

Ninho

  • Full Member
  • ***
  • Posts: 138
Re: SuSE: Help setting up 6-routing !
« Reply #1 on: September 14, 2009, 03:19:28 AM »

(ff.) What I've tried already :

- installed radvd from my distro's original medium
- created /etc/radvd.conf as follows :
____________________________________________________________________________
interface eth0
{
   AdvSendAdvert on;

   MinRtrAdvInterval 60;
   MaxRtrAdvInterval 200;

# Disable Mobile IPv6 support

   AdvHomeAgentFlag off;

# My /64 prefix from TunnelBroker :
#
   prefix 2001:470:xxxx:xxxx::/64
   {
      AdvOnLink on;
      AdvAutonomous on;
      AdvRouterAddr off;
   };

};
____________________________________________________________________________

- tried to launch the daemon (as root) : failed :=(
# radvd start
Starting router advertisement daemonstartproc:  exit status of parent of /usr/sbin/radvd: 1


- What's next ?
Logged

kriteknetworks

  • Sr. Member
  • ****
  • Posts: 259
    • aRDy Music
Re: SuSE: Help setting up 6-routing !
« Reply #2 on: September 14, 2009, 07:27:42 AM »

Start radvd manually, not via init script, its likely a syntax problem in its conf, or IPv6 forwarding isn't enabled. Check /proc/sys/net/ipv6/conf/all/forwarding, it should be set to 1, if not,
echo 1 > /proc/sys/net/ipv6/conf/all/forwarding, or sysctl -w net.ipv6.conf.all.forwarding=1.
If you need this set permanently, add the following line to /etc/sysctl.conf:

net.ipv6.conf.all.forwarding=1
Logged

Ninho

  • Full Member
  • ***
  • Posts: 138
Re: SuSE: Help setting up 6-routing !
« Reply #3 on: September 14, 2009, 08:29:38 AM »

Check /proc/sys/net/ipv6/conf/all/forwarding, it should be set to 1, if not,
echo 1 > /proc/sys/net/ipv6/conf/all/forwarding

Yeah!!! Thank you so much, Kriket ! I was starting to pull out what little hair I had left !

Logged