• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Netgear WPN824v2 do not pass protocol 41?

Started by Mendemizo, May 23, 2009, 01:40:51 PM

Previous topic - Next topic



I got a problem with IPv6-tunneling with my Netgear WPN824v2 router. Im trying to use my tunnel with a laptop running Ubuntu 9.04. I got it working fine with only my modem(my modem dosent have any dhcp or so).
Router WebGUI:

I entred WAN Setup

Connecect Automatically, as Required=ON
Disable SPI Firewall=ON
Default DMZ Server=ON, laptop)
Respond to Ping on Internet Port=ON
MTU Size (in bytes)=1500 bytes
NAT Filtering=Open

But, it still not work. Does anyone have any idea what I can do? Or does the router make this impossible?


EDIT: I just discoverd something. When I paste in this in the terminal on my laptop:

ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::
ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:1f06:e6::2/64
route -A inet6 add ::/0 dev sit1

I can't enter tunnelbroker.net anymore.


Information from ifconfig:

eth1      Link encap:Ethernet  HWaddr 00:12:f0:89:7e:43 
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::212:f0ff:fe89:7e43/64 Scope:Link
          RX packets:3249 errors:6 dropped:6 overruns:0 frame:0
          TX packets:714 errors:0 dropped:6 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60990095 (60.9 MB)  TX bytes:569668 (569.6 KB)
          Interrupt:21 Base address:0xa000 Memory:d0400000-d0400fff

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:608 (608.0 B)  TX bytes:608 (608.0 B)

sit0      Link encap:IPv6-in-IPv4 
          inet6 addr: :: Scope:Unknown
          inet6 addr: :: Scope:Compat
          UP RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sit1      Link encap:IPv6-in-IPv4 
          inet6 addr: 2001:470:1f06:e6::2/64 Scope:Global
          inet6 addr: fe80::c0a8:103/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:568 (568.0 B)


Since you're using an RFC 1918 private network with NAT, first make certain that your IPv4 tunnel endpoint specifies a routable IPv4 address (the address of your NAT device).  If you put in instead (a HE's server), then of course your tunnel won't work.


I have the exact same question. Does the Netgear WPN824v2 pass protocol 41? Without the Netgear, directly onto the modem, i got ipv6 working. So everyhing is configured correct.


Then I would say it's not passing protocol 41.

However, like snarked mentioned, you need to use your NAT'd address to create the tunnel


The tunnel is working fine without the netgear. On the hurricane site the ipv4 client adress is: 83.84.22X.XX. The tunnel on my pc is:

netsh interface ipv6 add v6v4tunnel IP6Tunnel
netsh interface ipv6 add address IP6Tunnel 2001:470:1f14:a8c::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f14:a8c::1

So is there any chance of getting this working with the Netgear (opening a port, disabling firewall?)


Disabling the firewall would let protocol 41 through.

Some routers also have a DMZ..you could try placing your host in there and seeing if that works


Tried to disable SPI firewall and DMZ host but no luck..