• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Unable to connect to TB ; Using A Cisco 2851 with ADSL, reachability woes

Started by tusharris, November 29, 2011, 07:59:53 AM

Previous topic - Next topic

tusharris

My connection looks something like this:

         PC-----------------------Cisco 2851-----------------------------ADSL Router----------------Internet
Windows 7                          12.4T with IPv6 support                         Bridge Mode


I've got the Cisco 2851 dialing to the ISP through the ADSL Router.
The ADSL Router is in bridge mode, and the dial out works fine.
The Dialer interface on the 2851 comes up with the public IP address fine.

I now face the following issues:

1.   The PC can only reach upto the 2851's Dialer interface; Cannot go further to the internet.
2.   The 2851 can reach the internet sites over IPv4 fine; However, while setting up the tunnel, Tunnel Broker is unable to ping the Dialer Interface.
Because of this, I am unable to set up a tunnel.

I've removed all the Access Lists on the 2851 and tried to see if this worked, but it did not.
I'm not sure why the TB cannot reach this external IP.

Could someone take a look and let me know what I am missing?
Would it make sense to add a route in the ADSL router to the dialer interface, though it is in Bridge mode?
FWIW, the ADSL box is a Beetel 110TC1, with AirTel India as the ISP.

My configuration is similar to the one in this guide:
                https://learningnetwork.cisco.com/docs/DOC-10847


//enable IPv6 routing
ipv6 unicast-routing


//configure the internal interface
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
ipv6 address <as assigned by Tunnel Broker>/64 eui-64
ipv6 enable

//ipv6 actually advertises ipv6 mtu in the router advertisements
//I used 1472 to account for the PPPoE and Tunnel Overhead
ipv6 mtu 1472



//configure the physical interface for PPPoE
interface FastEthernet0/1
description Physical Connection to DSL Modem
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable


//configure the PPPoE Dialer
interface Dialer1
description PPPoE dialer Interface
ip address negotiated
no ip unreachables
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username <USERNAME> password 0 <as assigned by ISP>


//PPPoE Dilaer list and VPDN Commands
dialer-list 1 protocol ip permit
vpdn enable
vpdn-group 1
request-dialin
  protocol pppoe


//IPv4 default route
ip route 0.0.0.0 0.0.0.0 Dialer1


//IPv4 NAT
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface Dialer1 overload


//IPv6 Default Route
ipv6 route ::/0 Tunnel0


TIA!
Tushar