Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: IPv6 News server problem  (Read 3511 times)

sav

  • readonly_member
  • Newbie
  • *
  • Posts: 2
IPv6 News server problem
« on: April 17, 2010, 05:27:03 AM »

I am having difficulty getting my tunnel to work with the newszilla6.xs4all.nl usenet server. If I dial a PPPOE connection from my PC and configure the tunnel then everything works 100%

The problem is if I try connect through my gateway(RouterOS), I establish the tunnel on my local machine and I can ping IPv6 servers and can browse IPv6 sites but I can't get my downloads to start. SABnzbd connects to newszilla6.xs4all.nl but doesn't download anything and eventually times out but I can ping6 and traceroute6 the address. I think it's a problem with port 119 and RouterOS but I don't know how to fix it.

In both cases I used the same commands to setup the tunnel

ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::216.66.80.26
ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:xxxx:xxx::x/64
route -A inet6 add ::/0 dev sit1
« Last Edit: April 17, 2010, 05:53:23 AM by sav »
Logged

snarked

  • Hero Member
  • *****
  • Posts: 758
Re: IPv6 News server problem
« Reply #1 on: April 17, 2010, 02:24:47 PM »

If you want, try connecting to my news server (news.snarked.org).  You should get a 502 reply, but if you do, then the application connected and port 119 is not being blocked on your end.
Logged

snarked

  • Hero Member
  • *****
  • Posts: 758
Re: IPv6 News server problem
« Reply #2 on: April 17, 2010, 06:48:14 PM »

Check for a private message.  Your port 119 is NOT being blocked.  I sent you the log entries that I have when your system tried to connect - for yor examination.

Since you didn't want your IPv6 address posted, that's why I sent it as a private message.

Perhaps port 119 at your preferred news server isn't open via IPv6?
Logged

jimb

  • Hero Member
  • *****
  • Posts: 805
  • ^^^ Warped picture
Re: IPv6 News server problem
« Reply #3 on: April 17, 2010, 07:34:59 PM »

Could be an MTU/PMTU problem.  Make sure you're not blocking ICMP.  And/or set an MTU on the tunnel interface of 1280.  "Connects but won't download" is a classic MTU issue.
Logged

sav

  • readonly_member
  • Newbie
  • *
  • Posts: 2
Re: IPv6 News server problem
« Reply #4 on: April 17, 2010, 11:33:37 PM »

If you want, try connecting to my news server (news.snarked.org).
Thanks snarked

Could be an MTU/PMTU problem.  Make sure you're not blocking ICMP.  And/or set an MTU on the tunnel interface of 1280.  "Connects but won't download" is a classic MTU issue.
Set MTU to 1280 and it's working, thanks.
Logged