Hurricane Electric's IPv6 Tunnel Broker Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Windows 7 - "IPv6 Connectivity: No Internet access"  (Read 18268 times)

throwbaca

  • Newbie
  • *
  • Posts: 2
    • View Profile
Windows 7 - "IPv6 Connectivity: No Internet access"
« on: August 08, 2010, 01:36:47 PM »

Good day,

Periodically, I am unable to access IPv6 resources by hostname on Windows 7. When this occurs, the status of the interface displays "IPv6 Connectivity: No Internet Access". The Network Connection Details shows the same autoconfigured address for IPv6 Address and Temporary IPv6 Address, and a valid IPv6 server, IPv6 gateway and link-local address. I am able to ping IPv6 addresses on the internet, but since windows thinks that there is no IPv6 connectivity it doesn't attempt to request AAAA records from the configured DNS server. This problem usually resolves itself after a few hours until it happens again.

Does anyone know what criteria Windows 7 uses to determine if there is IPv6 Connnectivity, or how to start troubleshooting this issue?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2234
    • View Profile
Re: Windows 7 - "IPv6 Connectivity: No Internet access"
« Reply #1 on: August 08, 2010, 03:07:38 PM »

Quote
Periodically, I am unable to access IPv6 resources by hostname on Windows 7. When this occurs, the status of the interface displays "IPv6 Connectivity: No Internet Access".

Mine always says this...I assume it's because I don't have a native IPv6 connection.

Quote
but since windows thinks that there is no IPv6 connectivity it doesn't attempt to request AAAA records from the configured DNS server.

I've never had this problem...I assume you've done an "nslookup" to confirm?
Logged

throwbaca

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Windows 7 - "IPv6 Connectivity: No Internet access"
« Reply #2 on: August 09, 2010, 05:54:12 PM »

Yes, when in this state nslookup returns AAAA records.


netsh interface ipv6 show addresses shows DAD State of Deprecated:


Interface 12: Wireless Network Connection

Addr Type  DAD State   Valid Life Pref. Life Address
---------  ----------- ---------- ---------- ------------------------
Public     Deprecated   23h52m13s   3h52m13s 2001:470:c1a5:aaaa:xxxx:xxxx:xxxx:xxxx
33
Temporary  Deprecated   23h52m13s   3h52m13s 2001:470:c1a5:aaaa:xxxx:xxxx:xxxx:xxxx
e3b
Other      Preferred     infinite   infinite fe80::5055:9e6:1473:9133%12

This seems to occur after resuming from a suspended state in windows 7. Other users are reporting the same issue here:

http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/61fb3e35-dc96-4845-90a5-f3a26f799254


No solution yet.
Logged

jhunax

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Windows 7 - "IPv6 Connectivity: No Internet access"
« Reply #3 on: August 10, 2010, 04:26:19 AM »

I am having a similar issue. IPv6 is connected, working fine, can browse, chat, but then it suddenly gets disconnected. Tunnel is still connected, I can still ping the tunnel server, but the IPv6 connectivity is entirely lost. Tried to restart my router but it's still the same. One time after I restarted my PC, all went back to normal. Now it's lost again and this time restarting both router and PC did not help. Any idea whats happening? The website says tunnels are UP.
Logged