• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

IPv6 refuses to work on my Linode box

Started by yuuvee, January 22, 2011, 05:31:27 AM

Previous topic - Next topic


Hi all! Registered and set up a tunnel to my home osx dev box real simply, and now I want to set up a tunnel for my VPS so I can have IPv6 there too. However, nothing I seem to do works to get my Linode to play nicely. I know others have had success with Linode so I'm pretty baffled.

The Linode wiki has an article on IPv6 connectivity with Hurricane Electric. Going by the instructions here on TunnelBroker and on that wiki page, I've tried using the Linux-route2 method, the Linux-net-tools method, and the manual interface file edit method (undoing the changes in between each attempt of course).

First I tried one method, and then I tried ping6 ipv6.google.com. It would simply hang until I ^C out of it, showing a 100% packet loss message thereafter. traceroute6 printed thirty lines of asterisks.

So I undo the configuration I'd done and tried the second method. Same results on ping and traceroute. Same for the third method.

So I think okay, maybe something is wrong with my network config elsewhere, let's try a fresh OS. I shutdown my Linode, boot into a fresh Ubuntu 10.10, and try all three methods there, all with no success (same result across the board).

I think well then, maybe it's an issue with Ubuntu 10.10. So I create a fresh CentOS 5.5 profile and try all three methods, again with no success.

Using an IPv6 ping tool I'd come across, it can ping the server IPv6 address (as provided by HE), but cannot ping the client IPv6 address even after setup has been done according to the instructions.

I'm a bit at a loss as to what my options are now. :p Anybody have any ideas?


Are they on the same network?  If so, just use your OSx machine to give it an IP address and route traffic.

So you're able to use your mac to get a tunnel up, but Ubuntu and CentOS don't work?  Same internet connection?


They're on different networks, so I've created a separate tunnel for each.

The osx box is my home dev box, whereas the ubuntu/centos/other-flavour box is a rented server some miles away from me.

The note about osx was kind of irrelevant on my behalf, I just wanted to show that I was able to get one box on the tunnel, but have hit a wall with the second box.

Even following a Linode forum thread where others are sharing their network config and matching it with my own tunnel IP information results in the same dead end.

Is there a chance there could be an issue with the tunnel itself and I should create a new one?


It's possible that it's a tunnel problem, but I've never seen it happen and it doesn't seem very likely. 

Do you know if the rented server place is blocking protocol41?


Once in a blue moon there's a problem with an individual TS account.  I think I recall seeing one or two.

It looks like Linode supports proto 41 passing, since they have wikis about setting up a HE tunnel.  Too bad they don't provide native IPv6.  ;)

You may want to send an email to ipv6@he.net

But check the basic stuff like, are u using the right IPv6 addresses, typos, etc.


I wish Linode did have native IPv6, yeah. :P There's been support for it on their forums but it still seems to be a bit away for now.

Double and triple checked for correct addresses and typos, all of it looks to be okay. I'll send an email off and see if HE has any clues. :)

Thanks for the help thus far ;D


Yeh native IPv6 is a lot easier said than done.  A lot of networks have legacy equipment, which doesn't support it, or if it does only supports it w/ CPU and not ASICs (so it's slow), or doesn't have feature parity with IPv4, etc, etc.  And the HW vendors have been slow to adopt IPv6 'cause of the chicken-egg situation of demand for feature/usage of IPv6.


Looks like it was an issue on HE's end, and that my IPv4 address didn't register in their system properly. It displayed on the tunnel details page, but I guess it wasn't set in some other portion of their system.

If anybody comes across this problem in the future, maybe try re assigning the client IPv4 address for the tunnel. If all else fails, give ipv6@he.net an email, they'll fix it up ;D