Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Administrator (Email) Test Woes  (Read 3609 times)

Mierdin

  • Newbie
  • *
  • Posts: 30
Administrator (Email) Test Woes
« on: January 23, 2011, 07:44:26 PM »

Okay, I truly apologize in advance if what's causing my problems is a stupid misconfiguration on my part, but I'm at the end of my rope and I've been staring at this thing for so long I can't think well enough to actually work the problem. Here goes:

I'm trying to do the "Administrator" certification test. I've set up MX records before with free dns providers, so I figured this should be a piece of cake. I set everything up with my 2 buck domain from godaddy. I tried sending the email, and I got the message:

No MX found for your domain. Failed to get AAAA

So, following my instincts and working the problem from the bottom up, I decided to do a test:

Code: [Select]
#>nslookup mierdinv6.info 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    mierdinv6.info
Addresses:  2001:5c0:1400:b::9979

#>nslookup mierdinv6.info ns2.he.net
Server:  ns2.he.net
Address:  216.218.131.2

*** ns2.he.net can't find mierdinv6.info: Server failed

#>nslookup mierdinv6.info ns3.he.net
Server:  ns3.he.net
Address:  216.218.132.2

*** ns3.he.net can't find mierdinv6.info: Server failed

As you can see, I resolved my domain's AAAA record correctly with google's servers. I also tried a number of other public dns servers - all came back with the correct AAAA record. However, both he.net ns servers I tried did not have any records at all.

Now I've read around these forums and it looks like the majority of folks' problems lie in either not setting the TTL to a small enough value, so that their changes don't propagate around quickly, or they don't wait long enough, or both.

I've set my TTLs to the lowest value godaddy will allow (30 mins) and I've kept everything in the same configuration for a few hours now.

From the looks of things, he.net's ns servers just can't resolve the domain. But that's weird because everyone else can.

Any ideas?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: Administrator (Email) Test Woes
« Reply #1 on: January 23, 2011, 07:48:52 PM »

Yeah a few

1) Wait longer
2) hope staff from he see this post and reset the cache
3) email ipv6@he.net and ask them to clear the cache
Logged

Mierdin

  • Newbie
  • *
  • Posts: 30
Re: Administrator (Email) Test Woes
« Reply #2 on: January 23, 2011, 08:24:42 PM »

Hmm...okay. I figured that might be a possibility. I've sent an email.

Is there something I'm doing wrong that's causing this? I set the TTL for all my records for 30 mins, are he.net's servers just refusing updates until a longer interval has gone by?
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1731
Re: Administrator (Email) Test Woes
« Reply #3 on: January 23, 2011, 10:03:52 PM »

not seeing an mx record

Code: [Select]
~$ dig mx mierdinv6.info

; <<>> DiG 9.4.2-P2.1 <<>> mx mierdinv6.info
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 22697
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mierdinv6.info.                        IN      MX

;; Query time: 7 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun Jan 23 22:02:28 2011
;; MSG SIZE  rcvd: 32

~$ dig mx mierdinv6.info +trace

; <<>> DiG 9.4.2-P2.1 <<>> mx mierdinv6.info +trace
;; global options:  printcmd
.                       74693   IN      NS      c.root-servers.net.
.                       74693   IN      NS      h.root-servers.net.
.                       74693   IN      NS      k.root-servers.net.
.                       74693   IN      NS      l.root-servers.net.
.                       74693   IN      NS      m.root-servers.net.
.                       74693   IN      NS      e.root-servers.net.
.                       74693   IN      NS      d.root-servers.net.
.                       74693   IN      NS      a.root-servers.net.
.                       74693   IN      NS      j.root-servers.net.
.                       74693   IN      NS      g.root-servers.net.
.                       74693   IN      NS      f.root-servers.net.
.                       74693   IN      NS      i.root-servers.net.
.                       74693   IN      NS      b.root-servers.net.
;; Received 497 bytes from 127.0.0.1#53(127.0.0.1) in 1 ms

info.                   172800  IN      NS      a0.info.afilias-nst.info.
info.                   172800  IN      NS      d0.info.afilias-nst.org.
info.                   172800  IN      NS      b0.info.afilias-nst.org.
info.                   172800  IN      NS      c0.info.afilias-nst.info.
info.                   172800  IN      NS      b2.info.afilias-nst.org.
info.                   172800  IN      NS      a2.info.afilias-nst.info.
;; Received 435 bytes from 2001:503:ba3e::2:30#53(a.root-servers.net) in 3 ms

mierdinv6.info.         86400   IN      NS      ns64.domaincontrol.com.
mierdinv6.info.         86400   IN      NS      ns63.domaincontrol.com.
;; Received 87 bytes from 2001:500:1c::1#53(d0.info.afilias-nst.org) in 20 ms

mierdinv6.info.         86400   IN      SOA     ns63.domaincontrol.com. dns.jomax.net. 2011012322 28800 7200 604800 86400
;; Received 103 bytes from 208.109.255.42#53(ns64.domaincontrol.com) in 22 ms

Also, to reiterate for the nth time, ns1-5 are NOT recursors. So unless we host the domain, don't query them looking for records we don't host.
« Last Edit: January 23, 2011, 10:14:49 PM by broquea »
Logged

Mierdin

  • Newbie
  • *
  • Posts: 30
Re: Administrator (Email) Test Woes
« Reply #4 on: January 24, 2011, 10:49:44 AM »

Alright, I changed the nameservers in godaddy to he.net's, then configured everything there and everything worked.

Also, to reiterate for the nth time, ns1-5 are NOT recursors. So unless we host the domain, don't query them looking for records we don't host.

This was my first time hearing it. Duly noted.
Logged