• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Windows 7 x64 as ipv6 router on a LAN - is it possible?

Started by holgersson, February 05, 2011, 06:41:13 AM

Previous topic - Next topic


Hi. I've succesfully set up my first ipv6 tunnel in my Window 7 x64. Now I'd like to experiment with the network a bit, and have fired up a Debian Squeeze in a VMWare VM. What I'd like to do is have my W7 box supppy ipv6 routing and IP address information to the Linux VM. I'm noob in ipv6, so I don't even know if this is possible at all. The VM is in a bridged konfiguration, my D-Link DIR-655 router is assigning its LAN ipv4 address via DHCP. Ipv4 connectivity is fine. Has anyone tried a similar setup? Any help would be greatly appreciated.


This will work fine.

You need to tell your Windows machine to do RA (Router Advertisements)  There are a couple of guides here on the HE forums that describe how to do what you want, and I know MS has a whole page devoted to it.  You just need to google RA windows 7 (or something similar)


The statements I'm running are the following:

Basic config:

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel
netsh interface ipv6 add address IP6Tunnel 2001:470:25:44d::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:25:44d::1

Then I tried to advertise routing (similar to this)

netsh interface ipv6 add address interface="Marvell1" address=2001:470:26:44d::101
netsh interface ipv6 set interface interface="Marvell1" advertise=enabled
netsh interface ipv6 set route prefix=2001:470:26:44d::/64 interface="Marvell1" nexthop=:: publish=yes
netsh interface ipv6 set route interface="Marvell1" prefix=2001:470:26:44d::/64 publish=yes

This setup doesn't work - the linux doesn't get routing info, not any IPv6 address besides its own default fe80 address. What could go wrong here?

My tunnel:

Server IPv6 address:    2001:470:25:44d::1/64
Client IPv6 address:    2001:470:25:44d::2/64
Routed /64:            2001:470:26:44d::/64


ive been trying to get this working for weeks now using 2 test laptops on a network.  both laptops have Vista.  I can get Laptop1 to advertise the prefix, and Laptop2 will configure its own IPv6 address using SAA.  the problem arises in getting Laptop2 to also get the default gateway (in this experiment, the gateway is Laptop1.)  whatever commands i try, Laptop2 will simply not get the gateway.

here's my thread if you want to try it out.

and, if you somehow get it to work... please tell me!  :D


Actually for some time I've given up on configuring this on Windows. I've set up a working IPv6 network in Linux under about 15 minutes, advertising included (radvd). Also in a VMWare VM. I'm going to try again on Windows 7, based on your great post you also mentioned. I'll get back here if I'm successful - or well, with more questions :)