Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  


Welcome to Hurricane Electric's forums!

Author Topic: quagga setup  (Read 4021 times)


  • Newbie
  • *
  • Posts: 1
quagga setup
« on: February 10, 2011, 09:26:48 AM »

Morning all.

I have set up a bgp ipv6 tunnel, and the tunnel is working fine.  I can see BGP messages flowing back and forth.

However, doing a tcpdump, i see the following:

me ->
        Open Message (1), length: 29
          Version 4, my AS <myasn>, Holdtime 180s, ID <myrouterid>
          Optional parameters, length: 0
he ->
        Notification Message (3), length: 21, OPEN Message Error (2),
subcode Capability Message Error (7)

i'm currently using quagga 0.99.17() from the FreeBSD 8.1-STABLE ports
collection, if that's of any help.

config currently it is:

 neighbor 2001:470:xxxx remote-as 6939
 neighbor 2001:470:xxxx description Hurricane Electric IPv6 Tunnel
 neighbor 2001:470:xxxx route-map ipv6-he-out in
 neighbor 2001:470:xxxx route-map ipv6-he-out out

 address-family ipv6
 network 2605:xxxx::/32
 neighbor 2001:470:xxxx activate

the route-map is a basic deny, so i can see what routes i get from you,
to make sure nothing blows up in my face.

the open i get from HE is:

        Open Message (1), length: 45
          Version 4, my AS 6939, Holdtime 180s, ID <herouterid>
          Optional parameters, length: 16
            Option Capabilities Advertisement (2), length: 6
              Multiprotocol Extensions (1), length: 4
                AFI IPv6 (2), SAFI Unicast (1)
                0x0000:  0002 0001
            Option Capabilities Advertisement (2), length: 2
              Route Refresh (Cisco) (128), length: 0
            Option Capabilities Advertisement (2), length: 2
              Route Refresh (2), length: 0

any suggestions?  my thought is that perhaps HE's side doesn't like the fact that i don't advertise any options/capabilities?

This is my first attempt at setting up an ipv6 BGP session.  So i may be missing something basic.


  • Newbie
  • *
  • Posts: 12
Re: quagga setup
« Reply #1 on: February 17, 2011, 04:15:05 AM »

Do you have probably a 4-byte ASN?