Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Win 8.0 64-bit Woes  (Read 7281 times)

ncoweb

  • Newbie
  • *
  • Posts: 1
Win 8.0 64-bit Woes
« on: July 13, 2013, 10:04:21 PM »

I am trying to set up my tunnel in Win 64-bit and am getting an error on the second command line given for Win vista/7 which results in:

Operation not allowed in WOW64.

Can anyone advise on a fix for this or an updated script?

Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715
Re: Win 8.0 64-bit Woes
« Reply #1 on: July 14, 2013, 06:13:00 AM »

I don't know what the second line is your running...can you please post the commands you ran?
Logged

ipv64hem

  • Newbie
  • *
  • Posts: 5
Re: Win 8.0 64-bit Woes
« Reply #2 on: July 24, 2013, 10:52:30 AM »

Same problem here with win 8.0xx64

The second line is:

netsh interface ipv6 add v6v4tunnel IP6Tunnel  x.x.x.x x.x.x.x
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1722
Re: Win 8.0 64-bit Woes
« Reply #3 on: July 24, 2013, 11:49:40 AM »

For 64bit, there was this thing that needed second line to read "interface=IP6Tunnel". I found this at least with 64bit Vista at the time. For 8, no idea, not using it. Dive into netsh locally and see what the command might be expecting. Look at the stickied post I made in this topic, under the Vista/7/2008 section. You'll see the quoted bit, that I put there for 64bit compatibility.
« Last Edit: July 24, 2013, 12:08:02 PM by broquea »
Logged

ipv64hem

  • Newbie
  • *
  • Posts: 5
Re: Win 8.0 64-bit Woes
« Reply #4 on: July 26, 2013, 06:47:45 AM »

Same error.

The command should work, according to the manual.
Logged

ipv64hem

  • Newbie
  • *
  • Posts: 5
Re: Win 8.0 64-bit Woes
« Reply #5 on: July 26, 2013, 07:21:36 AM »

I also get this:

Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. Alle rechten voorbehouden.

C:\Windows\system32>netsh
netsh>interface
In future versions of Windows, Microsoft might remove the Netsh functionality
for TCP/IP.

Microsoft recommends that you transition to Windows PowerShell if you currently
use netsh to configure and manage TCP/IP.

Type Get-Command -Module NetTCPIP at the Windows PowerShell prompt to view
a list of commands to manage TCP/IP.

Visit http://go.microsoft.com/fwlink/?LinkId=217627 for additional information
about PowerShell commands for TCP/IP.
netsh interface>

Logged

Tanner Ryan

  • Newbie
  • *
  • Posts: 15
    • Hamilton Weather
Re: Win 8.0 64-bit Woes
« Reply #6 on: July 26, 2013, 08:48:56 AM »

netsh interface ipv6 add v6v4tunnel IP6Tunnel  x.x.x.x x.x.x.x

Did you first disable teredo tunneling?
Logged

ipv64hem

  • Newbie
  • *
  • Posts: 5
Re: Win 8.0 64-bit Woes
« Reply #7 on: July 29, 2013, 06:40:59 AM »

Yes, I did disable teredo.

The error I'm getting has something to do with 64bit it seems. Nothing in the eventlog.
Logged

ipv64hem

  • Newbie
  • *
  • Posts: 5
Re: Win 8.0 64-bit Woes
« Reply #8 on: July 29, 2013, 07:58:24 AM »

Ok, problem solved.

When starting cmd.exe normally, it starts the one from c:\Windows\System32 (32 bits).
If I select 'Run As Administrator', it start the one from c:\Windows\SysWOW64 (64 bits), giving the Wow64 error.

I just browsed to c:\Windows\System32 in windows explorer, right click run-as administrator, and in the resulting cmd.exe (32 bits, administrator), the commands work!
Logged