• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.


Welcome to Hurricane Electric's Tunnelbroker.net forums!

Main Menu

Win 8.0 64-bit Woes

Started by ncoweb, July 13, 2013, 10:04:21 PM

Previous topic - Next topic


I am trying to set up my tunnel in Win 64-bit and am getting an error on the second command line given for Win vista/7 which results in:

Operation not allowed in WOW64.

Can anyone advise on a fix for this or an updated script?


I don't know what the second line is your running...can you please post the commands you ran?


Same problem here with win 8.0xx64

The second line is:

netsh interface ipv6 add v6v4tunnel IP6Tunnel  x.x.x.x x.x.x.x


For 64bit, there was this thing that needed second line to read "interface=IP6Tunnel". I found this at least with 64bit Vista at the time. For 8, no idea, not using it. Dive into netsh locally and see what the command might be expecting. Look at the stickied post I made in this topic, under the Vista/7/2008 section. You'll see the quoted bit, that I put there for 64bit compatibility.


Same error.

The command should work, according to the manual.


I also get this:

Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. Alle rechten voorbehouden.

In future versions of Windows, Microsoft might remove the Netsh functionality
for TCP/IP.

Microsoft recommends that you transition to Windows PowerShell if you currently
use netsh to configure and manage TCP/IP.

Type Get-Command -Module NetTCPIP at the Windows PowerShell prompt to view
a list of commands to manage TCP/IP.

Visit http://go.microsoft.com/fwlink/?LinkId=217627 for additional information
about PowerShell commands for TCP/IP.
netsh interface>

Tanner Ryan

Quote from: ipv64hem on July 24, 2013, 10:52:30 AM
netsh interface ipv6 add v6v4tunnel IP6Tunnel  x.x.x.x x.x.x.x

Did you first disable teredo tunneling?


Yes, I did disable teredo.

The error I'm getting has something to do with 64bit it seems. Nothing in the eventlog.


Ok, problem solved.

When starting cmd.exe normally, it starts the one from c:\Windows\System32 (32 bits).
If I select 'Run As Administrator', it start the one from c:\Windows\SysWOW64 (64 bits), giving the Wow64 error.

I just browsed to c:\Windows\System32 in windows explorer, right click run-as administrator, and in the resulting cmd.exe (32 bits, administrator), the commands work!