Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: [SOLVED] Hosts Not Autoconfiguring  (Read 3179 times)

twmjr

  • Newbie
  • *
  • Posts: 2
[SOLVED] Hosts Not Autoconfiguring
« on: February 19, 2014, 10:03:17 AM »

Here is my setup:

HE IPV6 < - > Cisco 871 WAN (F4) - Cisco 871 LAN (VLAN1) < - > en0 Mac OSX Mavericks (Windows7 VM)

I have my tunnel /64 configured on the F4 WAN interface of the 871. The tunnel works exactly as expected. IPv6 pings work across the tunnel and out onto the internet.

I have my allocated /48 configured on the VLAN1 interface of the Cisco 871. The port connected to my iMac's en0 interface is a standard access port (It was a trunk when I started this process, but I have reverted to a standard access port for simplification of troubleshooting) on VLAN1.

The trouble is that, when I bounce the en0 interface on the iMac, I can see a Router Solicitation message being sent (in Wireshark). I see my 871 respond with a Rouder Advertismenet message (and see periodic RA messages on top of it). The problem is that my iMac seems to simply ignore the RA message. It never autoconfigures a global address on the /48. The same exact behavior is seen on the Windows7 VM -- it sends RS, gets RA, does nothing with it. The RA message contains my /48 prefix. It also has the autonomous autoconfig bit set. I am at a loss as to what in the world is going on. If anyone has any ideas, I would love to hear them. Here is the relevant portion of my Cisco config (for the LAN):

Code: [Select]
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ipv6 address 2001:470:8BE4::/48 eui-64
 ipv6 enable
 ipv6 nd autoconfig prefix
 ipv6 nd prefix 2001:470:8BE4::/48 86400 86400
 ipv6 nd router-preference High
 ipv6 nd ra interval 30
end
ipv6 route ::/0 Tunnel0

Edit: One additional note -- if I hard-set an address on the iMac on my 48 prefix (e.g. 2001:470:8BE4::2/48), everything works exactly as you'd expect. It is simply that autoconfiguration is not working.

Thanks :)
« Last Edit: February 19, 2014, 02:51:44 PM by twmjr »
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1731
Re: Hosts Not Autoconfiguring
« Reply #1 on: February 19, 2014, 12:34:17 PM »

autoconfig uses /64 not /48
the intent of the /48 on the tunnel is if you need more /64 subnets than the one auto-allocated alongside your tunnel's PtP /64
« Last Edit: February 19, 2014, 01:23:29 PM by broquea »
Logged

twmjr

  • Newbie
  • *
  • Posts: 2
Re: Hosts Not Autoconfiguring
« Reply #2 on: February 19, 2014, 02:45:28 PM »

Thank you...I knew it had to be something simple I was overlooking.

I guess what threw me off is that the router just went ahead with the /48 and assigned itself an address using eui-64. I presumed the hosts would do the same thing and forgot all about the need for it to be a /64 prefix.

You are a hero. :)
Logged