Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Troubleshooting IOS config for ipv6 webserver  (Read 2859 times)

pyuengling

  • Newbie
  • *
  • Posts: 1
Troubleshooting IOS config for ipv6 webserver
« on: June 01, 2014, 11:18:26 AM »

I've got a Cisco 2851 router running c2800nm-adventerprisek9-mz.151-4.M8 and using the Zone Based Firewall features.

My tunnel to he.net works like a champ.  I can ping6 things, browse, and all my devices get assigned an ipv6 address.  All is good from the inbound to the outbound.

I've got a linux host on my internal network that is running nginx and I'm using he.net's DNS to provide AAAA dns.  I've verified that ipv6 for DNS and to the nginx web server work just fine.

Accessing the linux web server from the ipv6 internet isn't going so well though.  I can't get anything beyond my router from the "out zone" to the "in zone".  I figure with a global unicast address assigned to the webserver then it should be relatively easy getting access to the inside of my network, but that hasn't worked.

Any tips for troubleshooting?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2760
Re: Troubleshooting IOS config for ipv6 webserver
« Reply #1 on: June 02, 2014, 07:28:01 AM »

Code: [Select]
ipv6 unicast routing
?
Logged

seannon

  • Newbie
  • *
  • Posts: 1
Re: Troubleshooting IOS config for ipv6 webserver
« Reply #2 on: June 22, 2014, 08:33:55 PM »

have you checked to make sure your access-list rules are allowing the data? or the zone rules? you can totally have everything working in one direction, and failing in the other with a slight missed configuration.
Logged