• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Tunnel suddenly stopped working

Started by rnoble02, August 20, 2014, 12:31:49 PM

Previous topic - Next topic


I had my tunnel setup and working with several services configured, full dual stack for everything on my network, DNS and all. It's been working great for over a month. However, today, I tried to ping6 a server, and it wouldn't work. After investigating, my tunnel was down. I took down the tunneling interface and brought it back up, but I cannot ping6 anything on the internet, even the other end of the tunnel. I can ping6 other local hosts, and I can see the packets being accepted by ip6tables. I verified that my he-ipv6 tunnel interface does get configured correctly. I also verified that protocol 41 is being accepted and counting packets in iptables. I can't find any useful logs anywhere, so I have no idea what's wrong.

How can I troubleshoot this? Since I can't even talk to the tunnel endpoint, ping6 isn't going anywhere, and I don't know what else to look for.

My tunnel endpoint is an Ubuntu 10.04 server. I have a static v4 IP from my ISP, and my server hasn't had a configuration change of any kind in about three weeks. I hadn't even so much as logged into it in two weeks.


Off the top of my head...

1) email ipv6@he.net and have them verify their side is configured
2) while waiting on a reply to 1, use lg.he.net and ping/trace to your side of the tunnel and verify that you are getting the packets or not
3) if you see packets but still doesn't seem like it is working, review any changes you made to your system, like kernel updates, etc. Because if you are getting packets, then the HE side is configured correctly.


Thanks for the quick response. I think I found the problem though - it looks like the HE endpoint I use is down:

After more searching I found that I could use hping3 to trace my ipv6 connectivity, and it dropped after reaching an he.net server. I then found the status page, don't know how I missed it earlier.