Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: [Quagga] Server not sending routes to HE after migration  (Read 1741 times)

str0AT

  • Newbie
  • *
  • Posts: 4
    • View Profile
[Quagga] Server not sending routes to HE after migration
« on: September 23, 2015, 09:07:24 AM »

Hello,

Anyone with quagga exp here? I migrated from an Ubuntu 15 system to Ubuntu 14 - The tunnel to HE runs fine, can ping the other side and BGP peer IP, BGP comes up and gets all prefixes downloaded but it never seems to send any out, HE support sent me this:

Quote
  Route map for incoming advertisements is ipv6-customer-in
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:           23435          0

#sh bgp ipv6 uni neighbors 2001:470:12:103::2 received-routes

Total number of prefixes 0

My quagga config:

Quote
!
route-map NextHop6 permit 1
set ipv6 next-hop global 2001:470:12:103::1
!
router bgp x
 bgp router-id IP
 bgp log-neighbor-changes
 neighbor upstream peer-group
 neighbor upstream remote-as 6939
 neighbor upstream capability dynamic
 neighbor 2001:470:12:103::1 peer-group upstream
 neighbor 2001:470:12:103::1 description HE
 neighbor 2001:470:12:103::1 ebgp-multihop 10
 neighbor 2001:470:12:103::1 prefix-list pl-allowed-adv out
 neighbor 2001:470:12:103::1 route-map NextHop6 out
 maximum-paths 16
 address-family ipv6
network 2a05:dfc7:200::/43
 neighbor 2001:470:12:103::1 activate
 exit-address-family
!
ipv6 prefix-list pl-allowed-adv seq 2 permit 2a05:dfc7:200::/43
ipv6 prefix-list pl-allowed-adv seq 490 deny any

Can anyone help?

Thanks!
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1673
    • View Profile
    • Another IPv6 Blog...
Re: [Quagga] Server not sending routes to HE after migration
« Reply #1 on: September 23, 2015, 09:33:50 AM »

Is an IP address out of 2a05:dfc7:200::/43 configured anywhere on your system? Basically a pull-up/anchor route? Try putting an IP on loopback or a nic.
Logged

str0AT

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Quagga] Server not sending routes to HE after migration
« Reply #2 on: September 23, 2015, 10:06:35 AM »

I now added ::1 as IP on lo and reset quagga but still the same result :(
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1673
    • View Profile
    • Another IPv6 Blog...
Re: [Quagga] Server not sending routes to HE after migration
« Reply #3 on: September 23, 2015, 10:54:04 AM »

Did that create a route in your kernel entries? what is output of "ip -6 r s | grep -i 2a05:dfc7:200"
Logged

str0AT

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Quagga] Server not sending routes to HE after migration
« Reply #4 on: September 23, 2015, 12:37:24 PM »

Fixed - I'm an idiot and used the wrong IP for next hop.
Logged

paolino

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: [Quagga] Server not sending routes to HE after migration
« Reply #5 on: March 17, 2016, 02:14:00 AM »

at the moment I've got the same problem with this quagga config:

root@bgp:~# cat /etc/quagga/bgpd.conf
log file /var/log/quagga/bgpd.log
!
debug bgp events
debug bgp updates
debug bgp fsm
!
router bgp 135164
 bgp router-id 104.233.125.3
 neighbor 2001:470:d6:45::1 remote-as 6939
 neighbor 2001:470:d6:45::1 description Hurricane Electric IPv6 Tunnel via tunnelbroker.com
 neighbor 2001:470:d6:45::1 route-map he-ipv6 in
 neighbor 2001:470:d6:45::1 route-map he-ipv6 out
 redistribute kernel
 redistribute static
 redistribute connected
 address-family ipv6
 network 2602:ffc5:170::/47
 neighbor 2001:470:d6:45::1 activate
!
line vty
!
end
root@bgp:~#
in ifconfig I've this interface:
he-ipv6   Link encap:IPv6-in-IPv4
          inet6 addr: 2001:470:d6:45::2/64 Scope:Global
          inet6 addr: fe80::68e9:7d03/64 Scope:Link
          inet6 addr: 2602:ffc5:170::/128 Scope:Global
          UP POINTOPOINT RUNNING NOARP  MTU:1480  Metric:1
          RX packets:8234 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5773 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7131025 (6.8 MiB)  TX bytes:722130 (705.2 KiB)

and in netstat -nap:
tcp6       0      0 2001:470:d6:45::2:45849 2001:470:d6:45::1:179   ESTABLISHED
but:
> >                                 Sent       Rcvd
> >  Prefix activity:               ----       ----
> >    Prefixes Current:           26657          0

Can you explain howto solve?
Logged